Jasper Studio to Jasper Server Connection Problem

10

I have connection problem on jasper studio and jasper server connection.

Version Specs :

  •  Jasper Studio 6.9.0
  •  Jasper Server Community Edition 7.2.0 (on Google Cloud)

Jasper Studio gives the exception:

java.lang.NoClassDefFoundError: com/jaspersoft/studio/server/protocol/restv2/ClientQueryMapperProvider at com.jaspersoft.studio.server.protocol.restv2.RestV2ConnectionJersey.connect(RestV2ConnectionJersey.java:174) at ...

oondersahin's picture
Joined: Jun 28 2019 - 6:51am
Last seen: 4 months 2 weeks ago

Having the same issue, same specs except my report server is a physical install, internally hosted. 

trevor.schermerhorn - 4 months 1 week ago

5 Answers:

2

Hi,

I had the same problem. For me helped in Repository Explorer / Servers / [Servername] / Edit ... Server Connection / Advanced Settings the Activation of

[X] Use SOAP protocol only.

Hope that helps ...

 

 

 

hc_2's picture
46
Joined: Jul 17 2019 - 5:32am
Last seen: 4 months 5 days ago
0

I have a user who is getting the same error. When I try the suggested workaround, I get a 404 error. On my desktop, I can deploy to the same server without error using the REST protocol, which indicates that it's an issue with the user's installation of Jaspersoft Studio. Are there any other settings I can fiddle with to fix this? It seems like a classpath problem from the error message.

valeskyt's picture
Joined: Jul 25 2018 - 9:11am
Last seen: 1 month 3 days ago
0

I had the same problem. 

java.lang.NoClassDefFoundError: com/jaspersoft/studio/server/protocol/restv2/ClientQueryMapperProvider
    at com.jaspersoft.studio.server.protocol.restv2.RestV2ConnectionJersey.connect(RestV2ConnectionJersey.java:174)
    at com.jaspersoft.studio.server.protocol.ProxyConnection.connect(ProxyConnection.java:102)
    at com.jaspersoft.studio.server.WSClientHelper.checkConnection(WSClientHelper.java:92)
    at com.jaspersoft.studio.server.wizard.ServerProfileWizard.connect(ServerProfileWizard.java:94)
    at com.jaspersoft.studio.server.wizard.ServerProfileWizard.access$1(ServerProfileWizard.java:89)
    at com.jaspersoft.studio.server.wizard.ServerProfileWizard$2.run(ServerProfileWizard.java:68)
    at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:122)
 

exchangexing's picture
Joined: Jul 20 2019 - 2:31am
Last seen: 3 months 4 weeks ago
1
valeskyt's picture
Joined: Jul 25 2018 - 9:11am
Last seen: 1 month 3 days ago
0

downgrade to version 6.6 and it worked.

rodrigofercav's picture
Joined: Aug 23 2019 - 8:13pm
Last seen: 2 months 3 weeks ago
Feedback