Print summery band if Detail band overflows

0

Hi ,

I have requirement in my report as below :

1: Detail band data should not print in next page if detail band data overflows . I mean detail band data should come in first page only becasue in my report i have genearte only  1 page . Remaing detail information I am showing in summery band .For this I kept Split type property of detail band as 'Prevent' .  --(Is this work in rerport ?) . 

2: If detail band overflows then only Summery band data prints otherwise it should not print in pdf  . 

Kindly tell me how to achive this

Thanks

Rohit 

rohitit3031's picture
Joined: Oct 7 2018 - 11:22pm
Last seen: 2 months 3 weeks ago

Just wanted update For this I kept Split type property of detail band as 'Prevent' .  --(Is this work in rerport ?) .  - this option is not working . My report data is flowing to next page .

Kindly suggest .

Thanks

rohitit3031 - 2 months 3 weeks ago

Hello Team Members ,

Kindly help me to solve this issue.

Thank

Rohit 

rohitit3031 - 2 months 3 weeks ago

1 Answer:

0

The splitting type just tells the engine, if the detailband itself is allowed to split to the next page, if the remaining space at the current page isn't enough.

It does NOT tell you, that the report itself should just render one page at all!

So in your case, I would just place all your fields to the title section... this is rendered just once and should already has access to all fields of the first resulting record of your query. If you have more that one records you could than print the summary (printwhenexpression) with a hint ... $V{REPORT_COUNT} has perhaps the current (last) number of records.

C-Box's picture
1622
Joined: Jul 19 2006 - 5:58pm
Last seen: 4 days 10 hours ago
Feedback
randomness