JasperReports Library 6.8.0 Java Version Requirements

0

I see the readme states that support from Java 9 to 11 has been added.

Does this mean that Java 8 is no longer supported ?

 

Thanks

 

Dave

davidgarratt's picture
Joined: Sep 17 2013 - 8:13pm
Last seen: 2 weeks 3 days ago

1 Answer:

1

There is a following line in build.xml file. Since target and source still points to "1.8", it implies 1.8 is still supported. In fact, when I'm creating pull requests on JasperReports, I'm using 1.8  because of this.

<javac destdir="./build/classes" debug="true" optimize="false" target="1.8" source="1.8"

hozawa's picture
42045
Joined: Apr 24 2010 - 4:31pm
Last seen: 2 hours 13 min ago
Feedback