Jaspersoft upgrade from 6.3 to 7.1 login issue

0

I just upgraded Jaspersoft pro from version 6.3 to 7.1 using the steps provided in this link: https://community.jaspersoft.com/documentation/tibco-jasperreports-serve...

Everything went smooth and easy and Tomcat started very well. Now when I go to the login page, it clearly looks like the version 7.1 but in the side it says "What's new in Jaspersoft Version 6?". Did I miss anything during update?
Also, I cannot login to the Jaspersoft 7.1 using my account that is Admin account. Do I need to take any action to move the username and passwords from Version 6 to version 7?

 

Thank you,

 

ssaadat's picture
12
Joined: Jul 13 2016 - 7:39am
Last seen: 11 months 3 weeks ago

I found out that the issue for login was certificate. In addition, Friendly User gave me a proper answer on the issue of showing version 6.

ssaadat - 1 year 2 weeks ago

2 Answers:

1

Possibly when upgrading you have imported the previous repository archive with previous themes. I'd suggest to drop and recreate the JRS database, do the import minimal step and then when importing the repository archive add --skip-themes

As for the user, we'd need more details. Did you have encryption turned on in the previous version? Do you get any error messages in browser console or jasperserver.log files?

Friendly User's picture
Joined: Oct 8 2009 - 5:59am
Last seen: 18 hours 13 min ago
0

Hi,

If you use the pro version maybe you have access to the TIBCO professional support on support.tibco.com to get official support during your upgrade.

As a start of an answer, have you followed each steps list under the Upgrade Steps Overview in the page you shared? If you install Jaspersoft 7 separately (step 4), there is no reason it still shows the what's new in Jaspersoft 6 on the home page.

rpeguet's picture
7752
Joined: Mar 8 2011 - 2:06am
Last seen: 4 days 20 hours ago
Feedback
randomness