Trouble enabling lambda support

0

I'm using JasperStudio 6.6.0 on Linux. I'm having trouble getting lambdas to be recognised. I tried adding:

-Dorg.eclipse.jdt.core.compiler.codegen.targetPlatform=1.8
-Dorg.eclipse.jdt.core.compiler.compliance=1.8
-Dorg.eclipse.jdt.core.compiler.source=1.8

to my .ini file, and have confirmed these option are present in the output of "ps -eaf". However, I still get errors like this:

net.sf.jasperreports.engine.JRException: Errors were encountered when compiling report expressions class file:
1 error(s):
1. syntax error (expression#3) at column 18 in line
  false).map(x -> x.getKey()).getClass()
.
    at net.sf.jasperreports.engine.design.JRAbstractCompiler.compileReport(JRAbstractCompiler.java:206)
    at net.sf.jasperreports.eclipse.builder.JasperReportCompiler.compileReport(JasperReportCompiler.java:286)
    at com.jaspersoft.studio.editor.preview.view.control.ReportController.compileJasperDesign(ReportController.java:467)
    at com.jaspersoft.studio.editor.preview.view.control.ReportController.access$8(ReportController.java:452)
    at com.jaspersoft.studio.editor.preview.view.control.ReportController$1.run(ReportController.java:376)
    at org.eclipse.core.internal.jobs.Worker.run(Worker.java:56)

Any hints would be most welcome.

Thanks, Shaheed

srhaque's picture
10
Joined: Mar 16 2018 - 1:29pm
Last seen: 4 hours 17 min ago

Based on this thread I looked for what version of the org.eclipse.jdt.core.compiler I have nad it appears to be this one:

/opt/tibco/TIB_js-studiocomm_6.6.0/dropins/eclipse/plugins/org.eclipse.jdt.core.compiler.batch.nl_it_4.2.0.v20130724060447.jar

Is this 4.2.0.v20130724060447.jar recent enough? If not, I'd appreciate some guidance on how to swap a newer one in. I know how to spell Maven, but I'm not au fait with it beyond that.

srhaque - 3 days 16 hours ago

0 Answers:

No answers yet
Feedback
randomness