Error with DataMatrix

0

Hi, 

I have a bug or a error when I try to use a DataMatrix code in my report in the php, in jaspersoft studio the report works normaly, he print the DataMatrix but when I put in de php, I have a error, I tested without the code of DataMatrix and it works.

This is the code of DataMatrix:

<componentElement>
  <reportElement x="232" y="37" width="75" height="66" uuid="162f75f3-5070-4402-9650-ea6342d1997e"/>
  <jr:DataMatrix xmlns:jr="http://jasperreports.sourceforge.net/jasperreports/components" xsi:schemaLocation="http://jasperreports.sourceforge.net/jasperreports/components http://jasperreports.sourceforge.net/xsd/components.xsd">
    <jr:codeExpression><![CDATA[$F{CodigoDeBarras}]]></jr:codeExpression>
  </jr:DataMatrix>
</componentElement>

This is the errors:

Loading class `com.mysql.jdbc.Driver'. This is deprecated. The new driver class is `com.mysql.cj.jdbc.Driver'. The driver is automatically registered via the SPI and manual loading of the driver class is generally unnecessary.
Tue Oct 30 11:00:13 BRT 2018 WARN: Establishing SSL connection without server's identity verification is not recommended. According to MySQL 5.5.45+, 5.6.26+ and 5.7.6+ requirements SSL connection must be established by default if explicit option isn't set. For compliance with existing applications not using SSL the verifyServerCertificate property is set to 'false'. You need either to explicitly disable SSL by setting useSSL=false, or set useSSL=true and provide truststore for server certificate verification.
Warning: Could not get charToByteConverterClass!

Exception in thread "main" java.lang.NoClassDefFoundError: org/apache/batik/bridge/FontFamilyResolver
at net.sf.jasperreports.renderers.util.SvgDataSniffer.<init>(SvgDataSniffer.java:57)
at net.sf.jasperreports.renderers.util.SvgDataSniffer.getInstance(SvgDataSniffer.java:68)
at net.sf.jasperreports.renderers.util.RendererUtil.getSvgDataSniffer(RendererUtil.java:148)
at net.sf.jasperreports.renderers.util.RendererUtil.isSvgData(RendererUtil.java:107)
at net.sf.jasperreports.renderers.util.RendererUtil.isSvgData(RendererUtil.java:137)
at net.sf.jasperreports.engine.export.JRPdfExporter$InternalImageProcessor.process(JRPdfExporter.java:1575)
at net.sf.jasperreports.engine.export.JRPdfExporter$InternalImageProcessor.access$300(JRPdfExporter.java:1532)
at net.sf.jasperreports.engine.export.JRPdfExporter.exportImage(JRPdfExporter.java:1472)
at net.sf.jasperreports.engine.export.JRPdfExporter.exportElements(JRPdfExporter.java:1090)
at net.sf.jasperreports.engine.export.JRPdfExporter.exportFrame(JRPdfExporter.java:3117)
at net.sf.jasperreports.engine.export.JRPdfExporter.exportElements(JRPdfExporter.java:1098)
at net.sf.jasperreports.engine.export.JRPdfExporter.exportPage(JRPdfExporter.java:1053)
at net.sf.jasperreports.engine.export.JRPdfExporter.exportReportToStream(JRPdfExporter.java:917)
at net.sf.jasperreports.engine.export.JRPdfExporter.exportReport(JRPdfExporter.java:537)
at net.sf.jasperreports.engine.JasperExportManager.exportToPdfFile(JasperExportManager.java:155)
at net.sf.jasperreports.engine.JasperExportManager.exportReportToPdfFile(JasperExportManager.java:503)
at de.cenote.jasperstarter.Report.exportPdf(Report.java:327)
at de.cenote.jasperstarter.App.processReport(App.java:230)
at de.cenote.jasperstarter.App.main(App.java:102)
Caused by: java.lang.ClassNotFoundException: org.apache.batik.bridge.FontFamilyResolver
at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:349)
at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
... 19 more

I'm using the jdbc most current and the other reports I have in the code they works, this is not a problem, but he appoint that, the error is the second code.

Anyone knows how fix that ?

I'm using php with Yii2 FrameWork and the chrmorandi for jasper.

Gabriel Nadodoski

gabriel.nadoroski's picture
Joined: Oct 1 2018 - 2:05pm
Last seen: 11 months 2 weeks ago

1 Answer:

0

I found the solution, if you using JasperStarter only atualize the files, just do this he come it work again.

Here is the link where I do the download:

https://sourceforge.net/projects/jasperstarter/


Thanks !

gabriel.nadoroski's picture
Joined: Oct 1 2018 - 2:05pm
Last seen: 11 months 2 weeks ago
Feedback