Empty Subreports

0

Hi.  I'm trying to create a report that is composed of two subreports.  Both subreports are created and function on their own and use the same data adapter.  However, they are empty when run in the main report.  I created them by dragging the subreport elements in to the detail band, chose "Select an existing report", selected a "workspace resource",  selected the subreport,  and then chose the "same JDBC connection used to fill the master report".  There are no parameters needed as the subreports are independent.  The main report has the same data adapter but no query.  What am I doing wrong?  I tried pubhlinsdhing the subreports to the server and using that for the subreport, but I still get a "Document is Empty" error.

yus0359's picture
10
Joined: Feb 21 2018 - 11:41am
Last seen: 1 year 6 months ago

1 Answer:

0

Not sure what will fix your issue, but here's what I've learned:

* In your master report, do you have the Subreport properties | Subreport tab | Connection Expression set to:

$P{REPORT_CONNECTION}

?

* Do you have the Subreport properties | Subreport tab | Expression set to something like:

foo.jasper

, where foo is the name of your sub-report?

* Is the Subreport properties | Appearance tab, Size width and height definitely large enough?

* Have you saved the Sub-report? (with ^S). I've noticed that unless I explicitly save the sub-report that the master report won't see my changes in my sub-report.

* ?? Have you Compiled? (i.e. right click in project explorer and select Compile.) - not sure what this does, but sometimes it seems like it might help. ??

Create's picture
99
Joined: May 23 2018 - 10:12pm
Last seen: 8 months 4 weeks ago
Feedback
randomness