Installation upgrade from v6.1.0 to 6.4.2

0

I have uninstalled old version 6.1.0 and instlled v6.4.2

Getting below error::

Caused by: org.springframework.beans.factory.BeanDefinitionStoreException: Invalid bean definition with name 'attributesConfig' defined in ServletContext resource [/WEB-INF/applicationContext-rest-services.xml]: Cannot register bean definition [Generic bean: class [com.jaspersoft.jasperserver.remote.helpers.AttributesConfig]; scope=; abstract=false; lazyInit=false; autowireMode=0; dependencyCheck=0; autowireCandidate=true; primary=false; factoryBeanName=null; factoryMethodName=null; initMethodName=null; destroyMethodName=null; defined in ServletContext resource [/WEB-INF/applicationContext-rest-services.xml]] for bean 'attributesConfig': There is already [Generic bean: class [com.jaspersoft.jasperserver.remote.helpers.AttributesConfig]; scope=; abstract=false; lazyInit=false; autowireMode=0; dependencyCheck=0; autowireCandidate=true; primary=false; factoryBeanName=null; factoryMethodName=null; initMethodName=null; destroyMethodName=null; defined in ServletContext resource [/WEB-INF/applicationContext-remote-services.xml]] bound.
        at org.springframework.beans.factory.support.DefaultListableBeanFactory.registerBeanDefinition(DefaultListableBeanFactory.java:671)
        at org.springframework.beans.factory.support.BeanDefinitionReaderUtils.registerBeanDefinition(BeanDefinitionReaderUtils.java:148)
        at org.springframework.beans.factory.xml.DefaultBeanDefinitionDocumentReader.processBeanDefinition(DefaultBeanDefinitionDocumentReader.java:319)
        ... 32 more

akash14111985's picture
Joined: Jan 9 2018 - 8:00am
Last seen: 1 year 7 months ago

1 Answer:

1

Best to follow the upgrade guide steps for a smooth upgrade. See CHAPTER 4 UPGRADING FROM 4.5 - 6.2 TO 6.4 of the JASPERREPORTS® SERVER UPGRADE GUIDE

vchiem's picture
6444
Joined: May 1 2017 - 5:33pm
Last seen: 1 hour 13 min ago
Feedback