REST API & Collection parameters issue


I’m struggling with REST API (v2). Here is my case:

I need to pass parameters to my SQL query what uses SQL IN. I found several examples where this is explained.

In Jasper Studio (latest version), my parameter is named as ID_ARR. Param class is set to java.util.Collection (have tried List as well). Only name & class is set for parameter.


In SQL this is used like: where $X{IN, id, ID_ARR}


All works like charm when I use preview in my Jasper Studio.


Now I need to run this report via REST API request. This is URL for report:



Report will be returned just fine, BUT ID_ARR variable remains always empty and all data is returned from table, so where IN is not executed at all?

Any ideas what I’m doing wrong?


I use latest JasperStudio & Jasper Server (6.4.0)

jyka.saario's picture
Joined: Oct 23 2017 - 4:43am
Last seen: 1 year 6 months ago

Did you solve this issue?


I'm currently having the same problem but getting an error as the crosstab in the report is too large with all the results.



andrew.brooks_1 - 4 years 2 months ago

Was this ever worked out... I have the EXACT same issue.... Andrew did you ever figure it out?


aaron_17 - 4 years 1 month ago

hi All,

I am having the same issue. Its working fine on JasperStudio but not on jasperserver. Has anyone resolved it ?



anubha0408 - 3 years 6 months ago

0 Answers:

No answers yet