Input Controls are not working!



Input controls are not working in Jasper Server after publishing the reports from jasperstudio.

JasperServer : jasperreports-server-cp-6.4.0-bin

JasperStudio : JasperStudio 6.4.0.Final

I have runtim parameters in my report with different datasets, which is working fine in JasperStudio.

I published the same report to jasper server and entered the input parameners after running. Those values are not populated to queries in the report. Its showing as null in logs.

2017-10-12 11:05:38,688 DEBUG JRJdbcQueryExecuter,pool-4-thread-2:569 - Parameter #1 (TIME_FROM of type java.lang.String): null
2017-10-12 11:05:38,689 DEBUG JRJdbcQueryExecuter,pool-4-thread-2:569 - Parameter #2 (TIME_TO of type java.lang.String): null

Please help me with clear steps of how to map the parameters in jasperstudio to jasperserver?

Thanks in advance.

pardhasaradhi.naraharasetti's picture
Joined: Aug 22 2017 - 5:44am
Last seen: 4 months 3 weeks ago

I have the same issue with Jasperstudio 6.5.0 and Jasperserver 6.4.2,  with no solution yet

marioboy1 - 2 months 2 weeks ago

1 Answer:


I solved with two steps:

1. Create the parameter in Jasperserver input control.

2. Create the parameter inside the Jaspersever report, and called it from the repository

3. Reduce the lenght name of my parameter. I had ie. Par-PEF-yr as the parameter name, then I changed it to PAR and it worked for me.

4. The parameter inside Jasperstudio has to be the same name and data type. In my case I had in Jasperserver a number type and in Jasperstudio a java.lang.Integer type

marioboy1's picture
Joined: Feb 25 2017 - 7:50pm
Last seen: 2 months 5 days ago