Error while executing report

1

HI All,

I have four types of reports to be genrated using JasperServer Reports,

Two of the reports are working fine, whereas the other two are throwing the below mentioned error.

                             Error Message

There was an error on the server. Try again or contact site administrators. (Error UID: 5bcaec3f-507a-4dsasad-djsancis2332)                                                      

Everything is fine with the connectivity and server, I am not sure what could be reason for this error for only two reports.

The other two reports are working perfect.

Could anyone please afvise what could be causing this error!

Thanks in Advance.

sabrish.jackson007_1's picture
Joined: Jul 26 2017 - 4:20am
Last seen: 2 years 12 months ago

I am also getting the error as below, iam using jasper server for fist time

There was an error on the server. Try again or contact site administrators. (Error UID: a84512a9-891d-47a2-aecf-d42a7c4195f5)

could any one suggest how to clear the error.

shanmukeshpudi - 7 months 3 weeks ago

This is the most annoying feature in Jasper Server.  Before, you used to see what the error was and could determine it without having to bother an admin.  Can this be turned off to just display the error message?  This is not ideal for a dev server to get some GUID and then having to dig in a log.  It was better the way it was before.

lauren.glenn - 3 months 3 weeks ago

5 Answers:

2

Check in the apache tomcat directory : apache-tomcat\webapps\jasperserver\WEB-INF\logs\jasperserver.log

nicolas.veilleux's picture
Joined: Jul 13 2017 - 5:22am
Last seen: 2 years 11 months ago
0

Thank you Nicolas, we had the same probleme and you answer helped us a lot we found the reason of our problem in the log you mentionned (a permission denied on datasource access)

horseman's picture
114
Joined: Oct 17 2011 - 11:30pm
Last seen: 1 month 2 days ago
-1

I've Faced the same error!

I've got this error because there were some errors in DataSource. Please check your datasource connection by clicking on TEST CONNECTON Button

sudeep.duvvuru's picture
Joined: Oct 6 2015 - 10:03am
Last seen: 4 months 3 weeks ago
1

Bonjour a tous..

j'ai cette même erreur. J'ai verifié la connexion a la source de données, par le test qui etait ok.

J'ai egalement cherché le fichier jasperserver.log dans apache-tomcat mais là je ne sais pas comment corriger mon erreur:

ça me donne : Error EngineServiceImpl,pool-4-thread-2:1833 - Error while closing data sourceconnection

ErrorPageHandlerAction,http-apr-8080-exec-1:118 - Error UID

Caused by: Error executing SQL statement for: invoice

Erreur d'E/S: Socket read timed out

yoannelfriedayehui's picture
Joined: May 31 2018 - 1:33am
Last seen: 2 years 1 month ago
0

in the hope that some one may find my experince helpful :

In my case, I had PostgreSQL and  chose "sql"  for the query language.

That needed to be __ plsql __ !

Once I changed it, it solved that issue

quqnuss's picture
10
Joined: Feb 7 2020 - 9:18am
Last seen: 5 months 4 weeks ago
Feedback