After successful buildomatic build, jasperserver tables exist, but are all empty

0

I configured the default_master.propertes for my MySQL database.  Then I install JasperServer via js-install-ce.sh.  The build runs to completion and I see a BUILD_SUCCESS.  The foodmart and Sugarcrm schemas have populated tables.  But in the jasperserver schema, no tables have any rows.  For instance, the JIFILERESOURCE table is empty... so the webapp throws an exception on login, since all theme resources are stored in JIFILERESOURCE.

I haven't found anyone else online that seems to have had this problem.

I'm using the MySQL JDBC driver (mysql-connector-java-5.1.40-bin.jar).

 

Thanks,

Dave

david.miller_1's picture
Joined: Jun 19 2017 - 7:35am
Last seen: 2 years 8 months ago

Thanks @howaza for your help... I have tried your suggestion to manually create the MySQL database.  It didn't help... as before, the tables are successfuly created, but they have no rows (no tables in jasperserver schema have any rows).

david.miller_1 - 2 years 9 months ago

@hozawa, thanks for the suggestion... unfortunately it did not help.  The tables are still created, and the build still goes all the way to BUILD SUCCESSFUL with no errors or warnings.  All the jasperserver tables are still empty.  Still get an error when I open the webapp URL, due to not having any rows in JIFILERESOURCE.

Also I just tried JasperServer Commuity 6.4.0 which was released last week.  Same thing happens there.

david.miller_1 - 2 years 9 months ago

4 Answers:

0
hozawa's picture
59174
Joined: Apr 24 2010 - 4:31pm
Last seen: 9 months 3 weeks ago
0

The problem is with my MySQL installation.  I tried the same installer options with the official MySQL docker image and all was well.  When I find the problem with my custom MySQL installation I'll post another answer here.

david.miller_1's picture
Joined: Jun 19 2017 - 7:35am
Last seen: 2 years 8 months ago
0

I've used MySQL 5.5, 5.6, and 5.7. If the rows are being inserted, it may be the user your are using doesn't have permission to insert/update rows in the schema. JasperReports Server user requires admin privilege to the schema.

hozawa's picture
59174
Joined: Apr 24 2010 - 4:31pm
Last seen: 9 months 3 weeks ago
0

All, 

The issue is that our MySQL DBA had disabled autocommit.  The Jasper installer depends on autocommit to populate jasperserver tables... I know this, because with autocommit enabled, everything is fine.  Here is how to enable autocommit in the Jasper installer, for anyone else that has this problem.  Edit the file buildomatic/conf_source/ieCe/applicationContext-export-config.xml.  Find the data source bean.  Add this property:

<property name="connectionInitSqls"> <list> <value>set autocommit = true</value> </list> </property>

Then run the install in the normal way, and jasperserver schema will be populated.

david.miller_1's picture
Joined: Jun 19 2017 - 7:35am
Last seen: 2 years 8 months ago
Feedback