Unable to Save Datasource

0

Hi,

Have been struggling with this issue for the past couple of days. I seem to be unable to save my datasource even though the Test connection is successful.
I'm able to add users, organization and roles, but just can't seem to save a data source. Even saving the existing ones (audit) gives the same error
Below is the error i'm getting.

Any help would be much appreciated.

Thank you

sharkkae's picture
Joined: Jul 7 2016 - 8:12pm
Last seen: 3 years 2 months ago

5 Answers:

0

Are you able to connect to your JasperServer instance from within JasperReports Studio?  Perhaps you could try creating your datasource there instead using the Repository Browser.  If you're still unable to save the datasource then Studio might give more of an error message to work with.

Also, depending on how you did your install for JasperServer there might be a security permission issue keeping the application from modifying the database.  Perhaps double check your roles in the database itself.

manshack_one's picture
Joined: Aug 18 2009 - 9:29am
Last seen: 2 years 8 months ago
0

Your first and formost step must be to analyze the jasperserver.log and if possible, share it here on the forum.
Also using which user are you logging into jasperserver and if you arent using superuser or jasperadmin, what is the user permissions?

Regards,
KKriplani

kkriplani's picture
858
Joined: Sep 4 2015 - 2:18am
Last seen: 1 month 3 weeks ago
0

Hi manshack_one, yup I'm able to connect to the server instance within studio and able to add datasource.
Am using the root user for db access which is kinda strange, also, I'm able to add users and roles which are also insert statements
which kind of had me puzzled as to this behaviour.

Hi KKriplani,
The logs were empty, even with debug set on all loggers, nothing was sent to the logs when the save button was clicked.
I was using superuser as I have not set up any other users yet.

However I did notice that the browser was doing a POST / PUT ajax call to the rest interface which failed and resulted in a connection reset, 
but as usual, the logs are dead silent

Regards,
sharkkae

sharkkae's picture
Joined: Jul 7 2016 - 8:12pm
Last seen: 3 years 2 months ago
0

What about the catalina.log in the log folder of tomcat?

kkriplani's picture
858
Joined: Sep 4 2015 - 2:18am
Last seen: 1 month 3 weeks ago
0

i have the same issues, @sharkkae how to resolve the problem ? 

candra_napits's picture
Joined: Nov 21 2019 - 8:49pm
Last seen: 2 weeks 6 days ago
Feedback
randomness