Repository file resource could not be loaded

0

Hi, guys I'm trying to upload main report with a subreport to a jasper server. There is an image in my subreport and i have renamed it as "repo: SS-PU.jpg" also the subreport is named the same way:

"repo: subreport.jrxml" . But i get this error 

Repository file resource /reports/PeU_test/ExamProtocol_blank31_files/SS-PU.jpg could not be loaded

If i try to upload the subreport without an image there is no problem it works but i need the picture to be inside the subreport ...
In short can some one tell me how to upload a subreport to a main report with an image inside the subreport. 

ahmy_1's picture
23
Joined: Jun 9 2016 - 12:40am
Last seen: 6 months 4 days ago

2 Answers:

1

Well first of all I know jasper is sensitive to using "-" in any resource. Rather use "_".

Do you load the sub report onto jasper as a resource and then when you load your main reports you point to your subreport? 
If you do load you're subreport onto repo then do you load the image as a resource as well. 
Can you test the subreport seperatly in jasperserver to see if you have a path issues or incorrect load of resource onto jaspeserver? 

If repo: does not work try the direct to resource first to test and see if same issue persist. 

joseng62's picture
610
Joined: Dec 5 2014 - 2:43am
Last seen: 5 days 1 hour ago
0

Thanks, man the problem was that in the " - " and when i renamed it to " _ " everthing worked out. You are the best, thanks ^^

 

ahmy_1's picture
23
Joined: Jun 9 2016 - 12:40am
Last seen: 6 months 4 days ago
Feedback
randomness