Java v 1.6 or 1.7, but which UPDATE?

-1

Server Install Documentation for v5.2 (1.2 Java Version Supported) states:

JasperReports Server supports Java 1.6 and 1.7. Versions earlier than Java 1.6 are not supported.

Does this include ALL updates of 1.6 and 1.7, past/present/future? Keeping Java current help address security vulnerabilities, but want to avoid upgrading to an unsupported or untested release...

michael.buono's picture
Joined: Jul 19 2016 - 7:23am
Last seen: 1 year 2 weeks ago

1 Answer:

0

The Platform Support document for 5.2 is dated July 1, 2013.  It doesn't specify versions in more granularity than 1.6, 1.7.  There wouldn't have been any updates to 5.2 after that, so the last tested version would be a version of 1.7 that was in the wild at that date (or probably a little earlier, when we were doing the testing).

When we update the server, we do update the version of Java we test against.  Eventually we will add support for Java 1.8 and drop support for 1.6.  

Your best resource is the TIBCO JasperReports Server Supported Platform Datasheet, available under the Docs link on the wiki. The 6.3 version is available here: http://community-static.jaspersoft.com/sites/default/files/docs/jasperso....  Unfortunately, there is no version-free link.

elizam's picture
4158
Joined: Mar 5 2012 - 9:19am
Last seen: 2 weeks 2 days ago
Feedback