Can't run report with Web Service Data Source on JasperServer Commercial

0

I'm using Web Service Data Source. Install plug-in to Jaspersoft Studio and copy files to JasperServer, following this http://community.jaspersoft.com/project/web-service-data-source

I create and publish report in Jaspersoft Studio. My report receive json data from url and work well in Jaspersoft Studio. When I run report in JasperServer, I go error:

com.jaspersoft.jasperserver.api.JSException: Error filling report Arguments: at com.jaspersoft.jasperserver.api.engine.jasperreports.service.impl.EngineServiceImpl$FillResultListener.reportFillError(EngineServiceImpl.java:1294) at net.sf.jasperreports.engine.fill.BaseFillHandle.notifyError(BaseFillHandle.java:210) at net.sf.jasperreports.engine.fill.BaseFillHandle$ReportFill.run(BaseFillHandle.java:134) at com.jaspersoft.jasperserver.api.engine.jasperreports.service.impl.EngineServiceImpl$SynchronousExecutor.execute(EngineServiceImpl.java:922) at net.sf.jasperreports.engine.fill.BaseFillHandle.startFill(BaseFillHandle.java:164) at com.jaspersoft.jasperserver.api.engine.jasperreports.service.impl.EngineServiceImpl$AsynchronousReportFiller.fillReport(EngineServiceImpl.java:878) at com.jaspersoft.jasperserver.api.engine.jasperreports.service.impl.EngineServiceImpl.fillReport(EngineServiceImpl.java:1774) at com.jaspersoft.jasperserver.api.engine.jasperreports.service.impl.EngineServiceImpl$ReportFill.runWithDataSource(EngineServiceImpl.java:1118) at com.jaspersoft.jasperserver.api.engine.jasperreports.service.impl.EngineServiceImpl$ReportFill.runReport(EngineServiceImpl.java:1047) at com.jaspersoft.jasperserver.api.engine.jasperreports.service.impl.EngineServiceImpl$ReportRunnable.run(EngineServiceImpl.java:944) at com.jaspersoft.jasperserver.api.engine.jasperreports.service.impl.DiagnosticLoggingContextCompatibleExecutorService$1.run(DiagnosticLoggingContextCompatibleExecutorService.java:61) at java.util.concurrent.ThreadPoolExecutor.runWorker(Unknown Source) at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source) at java.lang.Thread.run(Unknown Source) Caused by: net.sf.jasperreports.engine.JRException: net.sf.jasperreports.engine.JRException: Error creating request at com.jaspersoft.webservice.data.query.WebServiceQueryExecuter.createDatasource(WebServiceQueryExecuter.java:184) at com.jaspersoft.webservice.data.query.WebServiceQueryExecuter.createDatasource(WebServiceQueryExecuter.java:1) at net.sf.jasperreports.engine.fill.JRFillDataset.createQueryDatasource(JRFillDataset.java:1129) at net.sf.jasperreports.engine.fill.JRFillDataset.initDatasource(JRFillDataset.java:696) at net.sf.jasperreports.engine.fill.BaseReportFiller.setParameters(BaseReportFiller.java:437) at net.sf.jasperreports.engine.fill.JRBaseFiller.fill(JRBaseFiller.java:526) at net.sf.jasperreports.engine.fill.BaseFillHandle$ReportFill.run(BaseFillHandle.java:119) ... 11 more Caused by: net.sf.jasperreports.engine.JRException: Error creating request at com.jaspersoft.webservice.data.util.WebServiceConnector.createRequestForWs(WebServiceConnector.java:174) at com.jaspersoft.webservice.data.util.WebServiceConnector.callWS(WebServiceConnector.java:133) at com.jaspersoft.webservice.data.query.WebServiceQueryExecuter.createDatasource(WebServiceQueryExecuter.java:172) ... 17 more Caused by: net.sf.jasperreports.engine.JRException: Verb should be POST or GET . is not a valid verb at com.jaspersoft.webservice.data.util.WebServiceConnector.createRequestForWs(WebServiceConnector.java:166) ... 19 more

What is wrong? Why appears error message "Verb should be POST or GET . is not a valid verb"? I try modify plug-in, and fix that, but another error remaining.

Please, help me!

lastname.name2016's picture
Joined: Feb 1 2015 - 10:37pm
Last seen: 2 years 10 months ago

1 Answer:

0

Hi, looks like the quey is wrong,

What version are you using (both jrs and webservice datasource)?

Can you post the query?

There is a dedicated tab in the query editor in Studio that will show you the Query

Otherwise you can find it in the jrxml

Thanks

G

gnatali's picture
4306
Joined: May 23 2014 - 10:47am
Last seen: 2 years 10 months ago
Feedback