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  • TIBCO JasperReports®​​​​​​​ Server 7.8.0 Installation Using Windows Binary Installer Might have Problem Starting Up


    Tom C
    • Features: JasperReports Server Version: v7.8 Product: JasperReports® Server

    Problem

    After "successfully" installing the TIBCO JasperReports® Server 7.8.0 using Windows installer (TIB_js-jrs_7.8.0_win_x86_64.exe) with all default out of the box options on a Windows 10 machine, this JasperReports® Server 7.8.0 instance fails to start with the following error:

    Could not locate: org.apache.commons.configuration2.io.FileLocator@4ff6da37[fileName=.jrsksp,basePath=C:Users{john_doe}
    

    Cause

    This Windows machine had previously installed JasperReports® Server version 7.2 and 7.5 generating keystore files with legacy and new server specific encryption keys. Under these special circumstances, the bitrock Tomcat package used in JasperReports® Server 7.8.0 installer somehow gets a third-party dependency induced error causing the keystore files' access permissions being missing for "Local Service" user. It appears that this installer changes Tomcat service on Windows under a new user called "Local Service'' which is different from all previous versions of JasperReports® Server installers.


    Solution

    We need to manually set the permission to allow this "Local Service" user to have read access to those keystore files.

    1. Locating ".jrsks" and ".jrsksp" files under Windows C:Users{john_doe} directory;

    2. Right click on ".jrsks" file and select Properties;

    3. Under Security Tab, click Edit;

      1_14.png.863d839ba1df7fb2a5ec30d7d918e038.png

    4. If you have "LOCAL SERVICE" in the group, go to step 6. Otherwise, click Add;

      screenshot_4353.png.3661e40d88c22c19f4df9d611b4689ef.png

    5. Enter "Local Service", click OK - continue to step 7;

      screenshot_4351.png.8e56c194585b1d1c776e0ca9bfc4ecee.png

    6. Select  "LOCAL SERVICE", and check Read permission;

      2_15.png.13bfbe0139ef59ac7e354398f201ba55.png

    7. Click OK (twice) to save the change;
    8. Repeat step 2 through step 5 for ".jrsksp" file;

    9. Restart server.

      Now JasperReports® Server 7.8.0 instance should be able to start up successfully;

      3_9.png.75e14f7961d2a12ec89dd9f93c0a6b27.png


    Note

    There is a defect report internally referenced as JS-59288 filed to address this problem.

    Jaspersoft will provide a permanent fix to prevent this error from happening in the first place to ensure a smooth and trouble free installation process and a positive and effortless user experience.

    We sincerely apologize for any trouble and inconvenience this issue has caused.  


    TTC-20200905

     

    3_9.png.ce5c66a297bb749b48466133df43bd1c.png


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