Jump to content
JasperReports Library 7.0 is now available ×
  • Set Detail band property "Split Type" to "Prevent"


    jzhou_1
    • Product: DynamicReports

    A customer is facing an issue with a report where the record cell is stretched incorrectly. Please see the screen shot, below, for reference.

    errot_layout.png.2130c289a1d3f1ac200a75ce1adbfd8b.png

    The problem was caused by setting "Stretch With Overflow" to true for the text fields in the Detail band. The text field was then automatically stretched when the record overflowed the defined height. 

    Here are a few options to resolve this problem: 

    1. Set the Detail band property "Split Type" to "Prevent":           this will force the overflow record to be printed in the next page instead of partially printed in two pages. 
    2. Set the Text Field property "Stretch With Overflow" to false:  the overflow part of the record will be automatically truncated if it exceed the defined filed height. 

     

    errot_layout.png.4a69120e46aec491b0b150e30d326026.png


    User Feedback

    Recommended Comments



    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

×
×
  • Create New...