Jump to content
Changes to the Jaspersoft community edition download ×
  • Configuring TIBCO JasperReports® Server Scheduler to send Reports using Gmail


    emistry
    • Features: JasperReports Server, Scheduler Version: v6.2, v6.2.0 Product: JasperReports® Server
    Just wanted to collate various articles on the net and provide a definitive page for Configuring TIBCO JasperReports® Server v6.2 to send email using your GMAIL account
     
    Step 1) Amend the applicationContext-report-scheduling.xml in the jasperreports-server-6.2.0apache-tomcatwebappsjasperserver-proWEB-INF directory
     
    Look for the reportSchedulerMailSender section and amend such that the section looks as below:
     
        <bean id="reportSchedulerMailSender" class="org.springframework.mail.javamail.JavaMailSenderImpl">
            <property name="host" value="${report.scheduler.mail.sender.host}"/>
            <property name="username" value="${report.scheduler.mail.sender.username}"/>
            <property name="password" value="${report.scheduler.mail.sender.password}"/>
            <property name="protocol" value="${report.scheduler.mail.sender.protocol}"/>
            <property name="port" value="${report.scheduler.mail.sender.port}"/>
            <property name="javaMailProperties">
                <props>
                    <prop key="mail.smtps.auth">true</prop>
                    <prop key="mail.smtps.starttls.enable">true</prop>
                </props>
            </property>
        </bean>
     
    Step 2) Amend the js.quartz.properties in the jasperreports-server-6.2.0apache-tomcatwebappsjasperserver-proWEB-INF directory
     
    Look for the report.scheduler section and amend as below 
     
    report.scheduler.web.deployment.uri=http://localhost:8080/jasperserver-pro
    report.scheduler.mail.sender.host=smtp.gmail.com
    report.scheduler.mail.sender.username=your@gmail.com
    report.scheduler.mail.sender.password=password
    report.scheduler.mail.sender.from=your@gmail.com
    report.scheduler.mail.sender.protocol=smtps
    report.scheduler.mail.sender.port=465
     
    PLEASE NOTE THAT IS SMTPS IN BOTH FILES
     
    During test, note that a "Username and Password not accepted" error can occur if you still have "Allow less secure apps" set to the default value of "OFF" in your gmail accounts settings at https://myaccount.google.com/lesssecureapps .  You may need to set this to ON
     

     


    User Feedback

    Recommended Comments

    There are no comments to display.



    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

×
×
  • Create New...