[#9496] - Jasper Studio Hangs when select Data Adapter at New report wizard

Category:
Bug report
Priority:
Normal
Status:
Resolved
Project: Severity:
Text
Resolution:
Open
Component: Reproducibility:
N/A
Assigned to:
0

Jasper Studio Hangs when select Data Adapter at New report wizard.
It says "Getting metadata for <DS_Name> Please wait..."

Can someone help?

v6.3.1
priyanka.jain's picture
Joined: Apr 24 2017 - 6:11am
Last seen: 4 years 4 months ago

3 Comments:

#1
  • Resolution:Open» No Change Required
  • Status:New» Resolved
  • Assigned:nobody» chicuslavic

This means, query editor get information about your tables. You have a progress bar on the bottom with a red square. Push on the red square, we call jdbc cancel method. It should cancel loading metadata.

#2

root cause : no Driver Classpath
Solution : (for my case, im using mysql DB)
1. create data adapter
2. choose Database JDBC Connection
3. JDBC Driver --> com.mysql.jdbc.Driver
4. JDBC Url --> jdbc:mysql://localhost/database
5. put username & password
6. go to tab Driver Classpath
7. Click Add
8. put mysql-connector-java-5.1.44-bin (can download)

AttachmentSize
Image icon data_adapter.png12.43 KB
#3
  • Priority:High» Normal
  • Severity:Major» Text
  • Reproducibility:Always» N/A
  • Resolution:No Change Required» Open
  • Assigned:nobody»

Hey man! Just wanted to say a big thank you, you saved me a lot of troubles!

Feedback
randomness