[#9336] - Page Format - 6.3.1 - not calculating properly

Category:
Bug report
Priority:
Normal
Status:
Resolved
Project: Severity:
Minor
Resolution:
Open
Component: Reproducibility:
Always
Assigned to:
0

When using Jaspersoft Studio 6.3.1, the Page Format doesn't calculate properly.
If you go into a report and set the following:
Width: 8.5 inches
Height: 11.0 inches
Page Orientation: Portrait
Top Margin: 0.5 inches
Bottom Margin: 0.5 inches
Left Margin: 0.25 inches
Right Margin: 0.25 inches
Columns: 5
Space: 0.125

This should provide a Column Width of 1.5, but instead produces a column width of 1.4723.
Should be 1.5 due to the following calculation:
[Width - (Left Margin + Right Margin + (Columns -1 * Space))] / Columns = Column Width
[8.5 - (0.25 + 0.25 + (5-1 * 0.125))] / 5 = Column Width
[8.5 - 1] / 5 = Column Width
7.5 / 5 = Column Width
1.5 = Column Width

This calculates correctly in Jaspersoft 6.0.0.

v6.3
mreynolds_2's picture
Joined: Jun 1 2016 - 5:49am
Last seen: 1 month 3 weeks ago

1 Comment:

#1
  • Status:New» Resolved
  • Assigned:» morlandin
Feedback
randomness