[#9301] - Data adapter HTTP request options : parameters and headers are complete ignored

Category:
Bug report
Priority:
Normal
Status:
Resolved
Project: Severity:
Major
Resolution:
Unable to Reproduce
Component: Reproducibility:
Always
Assigned to:
0

When doing (for example) a CSV Data Adapter and selecting a URL, you have an "Options" button to add parameters and http headers, but both are completely ignored and only 4 (default) headers are passed. This makes it in some cases impossible to pass in the correct "Accept" headers.

v6.3
natan.cox's picture
Joined: Feb 23 2017 - 3:43am
Last seen: 3 months 6 days ago

2 Comments:

#1
  • Resolution:Open» Unable to Reproduce
  • Status:New» Resolved
  • Assigned:» chicuslavic

Could you add more information? Your data adapter, so we can debug your specific case. I created 10 headers and I see all of them in the query.

#2

Hmm. Yes. I already kind of moved on with projects so it will be hard to reproduce.

Feedback
randomness