[#9081] - Jaspersoft Studio fails starting up

Category:
Bug report
Priority:
High
Status:
Feedback Requested
Project: Severity:
Major
Resolution:
Open
Component: Reproducibility:
Always
Assigned to:

When some reports are left open (not closed from the view), then the next time I open Jaspersoft Studio,
it fails to open, probably due to the fail of creating an preview editor of these reports. The only solution
for the moment is to rename the reports so that they are not found and then after opening the application
renaming back to their original name. From the log file it seems that the cause is a Null Pointer Exception,
specifically @ com.jaspersoft.studio.editor.AbstractJRXMLEditor.createPreviewEditorPage. Please see the attached
partial log file

AttachmentSize
Binary Data jstudio_partial.log221.28 KB
v6.3
g.mwralhs's picture
Joined: Sep 16 2016 - 2:41am
Last seen: 1 year 2 months ago

6 Comments:

#1

Note that Jaspersoft Studio is actually not quitting/crashing after the exception. You can actually see it in the Task Manager but the GUI is not shown but I have to kill it through the Task Manager and rename all the reports that had open tabs before closing.

#2
  • Status:New» Feedback Requested

Hi,
can you please detail on which system you are using? Windows/Mac/Linux?
Are you using the plugin version or the standalone one?

Regards,
Massimo.

#3

Hi,
I am using the standalone version on Windows 8.1.

#4

Hi,
I am using the standalone version on Windows 8.1.

#5

Hi,
is there any way you can provide/attach a "broken" workspace? It would help investigation. I just tried to play a bit with Studio 6.3.1 inside a Windows 8.1 32bit VM, but I did not noticed anything.
Looking at the previously attached error log I saw there are a lot of errors related also to possible missing classes/resources.

Maybe you can give it a try creating a fresh new workspace and re-import the projects and resources there and see if the problem keeps showing up.

Regards,
Massimo.

#6

Hi,
Ok, I'll try to create a new workspace and report back

Feedback