[#8846] - cannot build custom visualization component in studio 6.3

Category:
Bug report
Priority:
High
Status:
New
Project: Severity:
Major
Resolution:
Open
Component: Reproducibility:
Always
Assigned to:
0

We used to be able to build our cvc component in studio versions 6.0-6.1. Now having upgraded to 6.3, we are no longer able to build (with either jdk 1.7 nor jdk 1.8.) To reproduce:
simply right click build.js , nothing happens, no error in right hand panel, no pop up window. (unresponsive).

We tried building sample cvc's and same issue--
thanks
casey

v6.3
Custom Visualization Component
cyancey's picture
Joined: Mar 10 2014 - 12:47pm
Last seen: 7 months 3 weeks ago

4 Comments:

#1

Hi Casey,

we would need more info. It works in my case, so it could be something related to your environment.

What do you see in the Custom Visualization Component Console? It is a one of the console available in Studio.
You should see some output like:

Checking Java version
/Library/Java/JavaVirtualMachines/jdk1.7.0_75.jdk/Contents/Home/jre/bin/java -version
A valid version of Java was found
Compilation operation status:

Tracing dependencies for: sparkline

/Users/gtoffoli/JaspersoftWorkspaceV2.1/Sparkline/sparkline.min.js
----------------
./d3.min.js
./Sparkline.js

Compilation process terminated

AttachmentSize
jss_cvc_console.png65.05 KB
#2

Hey giulio,

My default system JRE set in JasperStudio 6.3.0 is 1.8.0.u77, which is set in the Jaspersoft Studio Professional.ini file automagically upon clean install:

-vm
../Eclipse/features/jre.macosx.cocoa.x86_64.feature_1.8.0.u77/jre/Contents/Home/lib/jli/libjli.dylib

Can we not build custom visualization components with bundled JRE?

thjanks
casey

p.s. Please note, NOTHING is generated in the console. Nothing happens at all when I click build component. No indication of a problem with the project whatsoever.
p.p.s I am Macosx sierra OS

#3

Ok, I had to do some toggling to get the right console to show up and found this in the console:
"Can not execute the command /Applications/TIBCO Jaspersoft Studio 6.3.0.final Pro.app/Contents/Eclipse/features/jre.macosx.cocoa.x86_64.feature_1.8.0.u77/jre/Contents/Home/bin/java -version
Set the Jaspersoft Studio Property com.jaspersoft.studio.components.customvisualization.javapath with the path of the bin folder of a Java 1.7 or above
"

I do not see this anywhere in the community documentation. Were you aware of this requirement? (this was not an issue before i upgrade to studio 6.3)

#4

I have the same issue using OS X Yosemite. I tried with beta version of 6.4.2 and it seems to be fixed

Feedback