[#8656] - Auto deploy on saving a report not working in Jaspersoft Studio 6.3

Category:
Bug report
Priority:
Immediate
Status:
Resolved
Project: Severity:
Minor
Resolution:
Fixed
Component: Reproducibility:
Always
Assigned to:
0

The auto-deploy prompt that appears on saving a report in studio does not appear in v6.3

v6.3
gururagavan2008's picture
Joined: Aug 6 2015 - 11:19am
Last seen: 7 months 2 weeks ago

6 Comments:

#1

Can't reproduce on that last JSS 6.3
Make sure that option [Show "Publish to JasperReports Server" dialog when report is saved] is set under (Window--Preferences--Jaspersoft Studio--JaspeReports Server Settings).
If it doesn't help - please, clarify your exact steps and better, attach screencast and report.

#2

This option is already enabled. (Refer screenshot)

As far as attaching the report goes, i do not know how that matters? because the issue occurs for all reports irrespective of the report. It is a setting issue within the studio and not a report-level issue.

Exact steps:
1) Create a new report
2) Modify it and save
3) Publish it to local server (localhost)
4) Modify the report
5) On clicking save:
Expected behavior:
Show a prompt that allows you to publish the report to the server
Actual behavior:
No prompt, no automatic publish.
So, I have to manually publish everytime i want to see my change in the server.

AttachmentSize
jasper_setting.png24.27 KB
#3

Going through your steps: http://screencast.com/t/rhKP20aZfnjF

Still can't reproduce. Your version is 6.3.1?

#4

It is Professional 6.3.0
Here is my screencast:
http://www.screencast.com/t/4PdYF5pvxz3H

#5

Has anyone been able to resolve this? I'm having the same issue.

#6
  • Resolution:Open» Fixed
  • Status:New» Resolved
  • Assigned:» chicuslavic

This has been fixed in last jss. But you have to wait for release or build it from svn trunk

Feedback
randomness