[#8241] - Scroll with mouse wheel fails

Category:
Bug report
Priority:
High
Status:
Assigned
Project: Severity:
Critical
Resolution:
Unable to Reproduce
Component: Reproducibility:
Unable to Reproduce
Assigned to:
0

Replicate

1. Exit Jaspersoft Studio 6.3.0 final, if running
2. Download beta release (see below)
3. Install into C:\Apps\04-Tools\JaspersoftStudio-6.3.1
4. Start Jaspersoft Studio
5. Open report template (for a report that has more than 200 lines of XML code)
6. Switch to source view
7. Use mouse wheel to scroll through the code

Expected Results

XML code scrolls upward.

Actual Results

Nothing happens.

Additional Details

Downloaded from: https://sourceforge.net/projects/jasperstudio/files/beta-release/package...

Scroll wheel cannot be used for any panel.

Using Trackman Marble - http://www.logitech.com/en-ca/product/trackman-marble

Using third-party driver for emulating a scroll wheel - http://blog.codekills.net/2011/06/04/scroll-wheel-emulation-for-the-trac...

Mouse wheel works as expected in 6.3.0 final, so a change between 6.3.0 final and this beta snapshot has caused the scroll wheel to stop working in Jaspersoft Studio. Note that the scroll wheel event is ignored by a few other applications. All native applications receive and respond to scroll wheel events just fine.

v6.3
Jaspersoft® Studio
thangalin's picture
364
Joined: Apr 21 2008 - 4:34am
Last seen: 4 days 10 hours ago

1 Comment:

#1
  • Reproducibility:Always» Unable to Reproduce
  • Resolution:Open» Unable to Reproduce
  • Status:New» Assigned
  • Assigned:» morlandin

Hi, can you try with the last version of JSS?

Feedback
randomness