[#6586] - Expression Editor does not work

Category:
Bug report
Priority:
High
Status:
Resolved
Project: Severity:
Critical
Resolution:
Fixed
Component: Reproducibility:
Always
Assigned to:
0

The Expression Editor window does not open

AttachmentSize
Package icon issueDetails.zip18.03 KB
ciukstar's picture
Joined: Sep 12 2014 - 11:25am
Last seen: 1 year 1 month ago

5 Comments:

#1
  • Resolution:Open» Fixed
  • Status:New» Resolved

Hi the problem seems related to some Xtext dependency.
We fixed a plugin manifest and a feature configuration. Next integration build will work fine.
In the meanwhile a possible workaround is to install the Xtext SDK from the Help > Install new software.
Another solution, would be to manually replace in the plugins folder of your Eclipse installation the com.jaspersoft.studio.editor.jrexpressions_6.2.0.final.jar file overwriting the old one with the updated one here: https://sourceforge.net/projects/jasperstudio/files/updatesite/6.2.0/plu...
We replaced today the files of the update site in order to silently fix the issue for upcoming 6.2.0 users. In this case please be sure to restart your Eclipse with the -clean flag.

Regards,
Massimo.

#2

Thank you, this solution works fine.

#3
  • Resolution:Fixed» Reopened

But with an update to 6.2.2 it seems to have come back :-(
The stack trace looks a bit different though:

!ENTRY org.eclipse.ui 4 0 2016-05-13 08:39:47.958
!MESSAGE Unhandled event loop exception
!STACK 0
java.lang.NoClassDefFoundError: org/eclipse/xtext/ui/shared/SharedStateModule
at com.jaspersoft.studio.editor.jrexpressions.ui.JRExpressionsActivator.getSharedStateModule(JRExpressionsActivator.java:104)
at com.jaspersoft.studio.editor.jrexpressions.ui.JRExpressionsActivator.createInjector(JRExpressionsActivator.java:76)
at com.jaspersoft.studio.editor.jrexpressions.ui.JRExpressionsActivator.getInjector(JRExpressionsActivator.java:67)
at com.jaspersoft.studio.editor.jrexpressions.ui.support.java.JavaExpressionEditorComposite.getInjector(JavaExpressionEditorComposite.java:324)
at com.jaspersoft.studio.editor.jrexpressions.ui.support.java.JavaExpressionEditorComposite.createEditorArea(JavaExpressionEditorComposite.java:228)
at com.jaspersoft.studio.editor.jrexpressions.ui.support.java.JavaExpressionEditorComposite.<init>(JavaExpressionEditorComposite.java:145)
at com.jaspersoft.studio.editor.jrexpressions.ui.support.java.JavaExpressionEditorSupport.createExpressionEditorComposite(JavaExpressionEditorSupport.java:45)
at com.jaspersoft.studio.property.descriptor.expression.dialog.JRExpressionPage.createControl(JRExpressionPage.java:91)
at org.eclipse.jface.wizard.Wizard.createPageControls(Wizard.java:175)
at org.eclipse.jface.wizard.WizardDialog.createPageControls(WizardDialog.java:705)
at org.eclipse.jface.wizard.WizardDialog.createContents(WizardDialog.java:597)
at org.eclipse.jface.window.Window.create(Window.java:430)
at org.eclipse.jface.dialogs.Dialog.create(Dialog.java:1096)
at org.eclipse.jface.window.Window.open(Window.java:792)
at com.jaspersoft.studio.swt.widgets.WTextExpression$3.widgetSelected(WTextExpression.java:220)
at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:248)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:84)
at org.eclipse.swt.widgets.Display.sendEvent(Display.java:4362)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:1113)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:4180)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3769)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$4.run(PartRenderingEngine.java:1127)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:337)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1018)
at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:156)
at org.eclipse.ui.internal.Workbench$5.run(Workbench.java:694)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:337)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:606)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:150)
at com.jaspersoft.studio.rcp.intro.Application.start(Application.java:99)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:380)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:235)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:669)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:608)
at org.eclipse.equinox.launcher.Main.run(Main.java:1515)
Caused by: java.lang.ClassNotFoundException: An error occurred while automatically activating bundle org.eclipse.xtext.ui.shared (714).
at org.eclipse.osgi.internal.hooks.EclipseLazyStarter.postFindLocalClass(EclipseLazyStarter.java:116)
at org.eclipse.osgi.internal.loader.classpath.ClasspathManager.findLocalClass(ClasspathManager.java:531)
at org.eclipse.osgi.internal.loader.ModuleClassLoader.findLocalClass(ModuleClassLoader.java:324)
at org.eclipse.osgi.internal.loader.BundleLoader.findLocalClass(BundleLoader.java:327)
at org.eclipse.osgi.internal.loader.sources.SingleSourcePackage.loadClass(SingleSourcePackage.java:36)
at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:398)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:352)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:344)
at org.eclipse.osgi.internal.loader.ModuleClassLoader.loadClass(ModuleClassLoader.java:160)
at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
... 42 more
Caused by: org.osgi.framework.BundleException: Exception in org.eclipse.xtext.ui.shared.internal.Activator.start() of bundle org.eclipse.xtext.ui.shared.
at org.eclipse.osgi.internal.framework.BundleContextImpl.startActivator(BundleContextImpl.java:792)
at org.eclipse.osgi.internal.framework.BundleContextImpl.start(BundleContextImpl.java:721)
at org.eclipse.osgi.internal.framework.EquinoxBundle.startWorker0(EquinoxBundle.java:941)
at org.eclipse.osgi.internal.framework.EquinoxBundle$EquinoxModule.startWorker(EquinoxBundle.java:318)
at org.eclipse.osgi.container.Module.doStart(Module.java:571)
at org.eclipse.osgi.container.Module.start(Module.java:439)
at org.eclipse.osgi.framework.util.SecureAction.start(SecureAction.java:454)
at org.eclipse.osgi.internal.hooks.EclipseLazyStarter.postFindLocalClass(EclipseLazyStarter.java:107)
... 51 more
Caused by: java.lang.NoClassDefFoundError: org/eclipse/xtext/generator/trace/ITraceForStorageProvider
at org.eclipse.xtext.ui.shared.internal.SharedModule$2.configure(SharedModule.java:121)
at com.google.inject.PrivateModule.configure(PrivateModule.java:97)
at com.google.inject.spi.Elements$RecordingBinder.install(Elements.java:223)
at org.eclipse.xtext.ui.shared.internal.SharedModule.configure(SharedModule.java:117)
at com.google.inject.AbstractModule.configure(AbstractModule.java:59)
at com.google.inject.spi.Elements$RecordingBinder.install(Elements.java:223)
at com.google.inject.spi.Elements.getElements(Elements.java:101)
at com.google.inject.internal.InjectorShell$Builder.build(InjectorShell.java:133)
at com.google.inject.internal.InternalInjectorCreator.build(InternalInjectorCreator.java:103)
at com.google.inject.Guice.createInjector(Guice.java:95)
at com.google.inject.Guice.createInjector(Guice.java:72)
at com.google.inject.Guice.createInjector(Guice.java:62)
at org.eclipse.xtext.ui.shared.internal.Activator.initializeInjector(Activator.java:75)
at org.eclipse.xtext.ui.shared.internal.Activator.start(Activator.java:114)
at org.eclipse.osgi.internal.framework.BundleContextImpl$3.run(BundleContextImpl.java:771)
at org.eclipse.osgi.internal.framework.BundleContextImpl$3.run(BundleContextImpl.java:1)
at java.security.AccessController.doPrivileged(Native Method)
at org.eclipse.osgi.internal.framework.BundleContextImpl.startActivator(BundleContextImpl.java:764)
... 58 more
Caused by: java.lang.ClassNotFoundException: org.eclipse.xtext.generator.trace.ITraceForStorageProvider cannot be found by org.eclipse.xtext.ui.shared_2.8.4.v201508050135
at org.eclipse.osgi.internal.loader.BundleLoader.findClassInternal(BundleLoader.java:439)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:352)
at org.eclipse.osgi.internal.loader.BundleLoader.findClass(BundleLoader.java:344)
at org.eclipse.osgi.internal.loader.ModuleClassLoader.loadClass(ModuleClassLoader.java:160)
at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
... 76 more

#4

Hmm...
After replacing the jrexpressions files and starting eclipse with "-clean" (which result in an error: An error occurred. See the log file null.) the problem still existed.
But then after reverting the original jrexpressions file the problem was gone!?!?

So for ME the problem is solved.

#5
  • Resolution:Reopened» Fixed
  • Assigned:nobody» mrabbi
Feedback