[#5596] - Upload Error: org.apache.http.client.HttpResponseException: Not Implemented

Category:
Bug report
Priority:
Immediate
Status:
Confirmed
Project: Severity:
Block
Resolution:
Open
Component: Reproducibility:
Always
Assigned to:
0

Hi at all,

I have a problem with uploading an report with Jaspersoft Studio 6.1.1 on JasperServer 6.0.1.
This report contain 1 subreport, some input controls and a resource bundel for internationalization of the report.

In Jaspersoft Studio everything works fine. But if I want to upload the report I can choose the Resources which hve to be published. I can select the input controls which are already available at the JasperServer also I can choose the .properties file without any problems. I can choose a Data Source too, now problem at all. But if I click Finish I get an exception. "Exception, if you want to see more information look into details Reason: Not implemented" and this text below in the details window:

org.apache.http.client.HttpResponseException: Not Implemented

at com.jaspersoft.studio.server.protocol.restv2.RESTv2ExceptionHandler.handleException(RESTv2ExceptionHandler.java:79)

at com.jaspersoft.studio.server.protocol.restv2.ARestV2ConnectionJersey.toObj(ARestV2ConnectionJersey.java:52)

at com.jaspersoft.studio.server.protocol.restv2.RestV2ConnectionJersey.addOrModifyResource(RestV2ConnectionJersey.java:515)

at com.jaspersoft.studio.server.protocol.ProxyConnection.addOrModifyResource(ProxyConnection.java:314)

at com.jaspersoft.studio.server.publish.Publish.publishResources(Publish.java:198)

at com.jaspersoft.studio.server.publish.Publish.publish(Publish.java:67)

at com.jaspersoft.studio.server.publish.wizard.Publish2ServerWizard$3.run(Publish2ServerWizard.java:302)

at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:121)

The same problem with the Jaspersoft Studio Versions after 6.0.3
With 6.0.3 everything works. No problem with uploading.

Is there a workaround for this?

I'll try to create an example file for you, because I'm not allowed to give the original file for testing.

Kind regards
Christina

v6.1
ckampshoff's picture
Joined: Sep 23 2009 - 6:25am
Last seen: 6 months 1 week ago

6 Comments:

#1

Hi again,

I tried to create a report sample so that someone can look after this. But If I try to reproduce the error it hadn't happen. The uploading worked fine. With my .properties files I use on your production system.
So I'm facing the problem to search for the origin of my problem with the uploading.

Can someone give me a hint what the mentioned error message should mean to me? Where I have to search for my problem?

Kind regards
Christina

#2
#3
  • Resolution:Open» Unable to Reproduce
  • Status:New» Resolved
  • Assigned:nobody» chicuslavic

could you retest on the latest JSS? 6.2

we need a sample to be able to reproduce

#4
  • Assigned:chicuslavic» igadzhega
#5
  • Assigned:igadzhega» chicuslavic
#6
  • Priority:High» Immediate
  • Severity:Critical» Block
  • Resolution:Unable to Reproduce» Open
  • Status:Resolved» Confirmed
  • Assigned:nobody»
Feedback