[#4881] - does not create connection to Hibernate 4 (mysql 5.6)

Category:
Bug report
Priority:
High
Status:
Confirmed
Project: Severity:
Critical
Resolution:
Suspended
Component: Reproducibility:
N/A
Assigned to:
0

i can not create connection to hibernate in jasper studio v6.1 (same in eclipse luna plugin in) but when i installed jasper studio v5.6.1 this worked perfect for me kindly fix this bug thanks

v6.1
mohsinazeemrind's picture
Joined: Jun 2 2015 - 1:04pm
Last seen: 6 months 2 weeks ago

2 Comments:

#1
  • Status:New» Feedback Requested

Hi,
can you please details the steps that you are performing in Studio, like data adapter creation + library (and sources) in the project?
Currently in JSS there is a built-in plugin that ship Hibernate version 3.2.0.GA. This libraries are also available to be added at project level using the contributed library Hibernate 3.2.0.GA library.

Unfortunately being able to work with multiple versions of Hibernate appears to be quite cumbersome. We are trying to do our best in adding out-of-the-box support also for Hibernate 4 in next upcoming release.
It is worth mentioning that JR team added support for Hibernate 4 at code level only in the latest release (not released yet).
Having a real example to debug like yours could help.

Thanks.
Regards,
Massimo.

#2
  • Resolution:Open» Suspended
  • Status:Feedback Requested» Confirmed

Put in suspended state since there are currently technical issues in supporting both versions (classloading problems, project classpath issues, etc.).
A further investigation, together with JR team is needed to support out of the box in Studio also Hibernate 4.

Regards,
Massimo.

Feedback