[#4746] - Dataset Return Values Problem

Category:
Bug report
Priority:
Urgent
Status:
New
Project: Severity:
Block
Resolution:
Open
Component: Reproducibility:
Always
Assigned to:
0

There are fundamental issues trying to define Return Values from a Dataset Run object used in a table element within a main report.

I have created a post describing the problem here: http://community.jaspersoft.com/comment/814111

This feature just does not work, you cannot correctly define a return value form the dataset. From my understanding the flow should be as follows:

Sub dataset variables -> (Return Values mapping) -> main report variables

Whereas the current forms are written as though the data flow is from the main report to the dataset, i.e:

Main dataset variable -> (Return Values mapping) -> sub-dataset variable

v6.0.4
Dataset Run
ianfoulds's picture
Joined: Nov 15 2013 - 11:03am
Last seen: 3 months 2 weeks ago

8 Comments:

#1
#2
  • Severity:Block» Major
  • Resolution:Open» Fixed
  • Status:New» Resolved

Hi, You were right about the swapped from and to. The problems raised by were fixed however.

#3

Hi Morlandin

I've tested this in 6.04 so has it been fixed in the current development code? What release will this be included in?

#4

It doesn't seem to work in JasperStudio 6.1 final. I am still getting null values in the main report. Any news, when the fix will be released?

#5
  • Assigned:nobody» morlandin

Hi, It seems to work for me, I've attached a report where I use the return value to print a variable with the last value of one of the fields.
The reason of your problem can be two:
- The first one is that you have configured something bad
- The second one is a JasperReports (and not Jaspersoft Studio) bug
About the second one, all the report are executed trough JasperReports, so if you don't have strange error from JSS and the generated JRXML seems correct at source level then it is not a JSS fault. We can do nothing about the JR bugs, they are followed by a different team. I can suggest you as first thing to look and test my report (because maybe it is working because I have a dev version of JR), it use the sample db as adapter so it is pretty easy to have it working. If it work check the differences between mine and yours to understand what is not working. If after all this everything seems correct but still not working, you can try to create a question or open a bug in the JR report section of this community.

Best Regards

AttachmentSize
Binary Data blank_a4.jrxml6.77 KB
#6

Hi morlandin,

I am using 6.1.1 final version of Jasper Studio and I am facing same issue.
return value from dataset is null in the main report.

I checked your sample report.
The reason its working in sample report is the report variable is places in Summary band.
If you place the same variable in Detail band it returns null.

Please let me know if there is any workaround to get return values in Detail band.

Regards,
Usman
usman_ganik@hotmail.com

#7

Hi Usaman,

Try to set Evaluation Time to Report for main dataset variable.

#8
  • Priority:Normal» Urgent
  • Severity:Major» Block
  • Resolution:Fixed» Open
  • Status:Resolved» New

I have the same Issue with Version 6.6.0. And it's for me like a blocker, because it's a feature I need always.
I tried to read JSON Data. My Workaround to get Data from a subset in a Table is to export my Adapter into XML file and to load the XML File in Table or List go to Datasubset and set the XML file same as my default Adapter as my Adapter for Data subset and then Jasper Studio is showing me the data

Feedback
randomness