[#3959] - copy paste reports fails between servers

Category:
Bug report
Priority:
Urgent
Status:
Closed
Project: Severity:
Trivial
Resolution:
Won't Fix
Component: Reproducibility:
N/A
Assigned to:
0

when i copy paste a report unit between servers in JasperStudio
i get an exception : the value "path to the jrxml file" for parameter "resourceReference.uri" is invalid..

mortias's picture
25
Joined: Jan 12 2011 - 1:11am
Last seen: 1 year 6 months ago

5 Comments:

#1
  • Priority:Normal» Urgent
  • Severity:Major» Trivial
  • Assigned:nobody»
#2
  • Assigned:» chicuslavic

hmm, I'll test copy paste between servers, however this could be complicated because servers are not the same

better is to use export which will export resources in a zip file, then import this zip file into the destination server

#3
  • Status:New» Acknowledged
#4

if you do an export it updates the linked resources, meaning
if you have a datasource X(1) pointing in dev to dev,
and a datasource X(2) (same name) in test pointing to test
when you import the report with datasource X(1) from dev to test, it updates the X(2) to X(1) !
which is not correct, it should use X(2) because it's declared but it shouldn't update it (or at least you should be able to choose it (merge/delta)

#5
  • Resolution:Open» Won't Fix
  • Status:Acknowledged» Closed

[CLEANING UP TRACKER]

Copy paste between servers not supported.

Feedback