[#3710] - JSS 5.6.1 beta does not allow fields/paramaters to be dropped in the report

Category:
Bug report
Priority:
Normal
Status:
Feedback Requested
Project: Severity:
Major
Resolution:
Open
Component: Reproducibility:
Always
Assigned to:
0

Hi,

In a list, we can no longer drag fields or paramaters into the design view. Creating a field manually and typing the $F/P{...} manually does work.

The error we get: "You drop an object from a subdataset into a report, this is not possible".

The error is wrong, I am in the subreport's context, inside the list.

Kind regards,
Maarten @ Yesplan

AttachmentSize
Image icon screenshot_2014-07-02_10.14.32.png21.5 KB
v5.6
mvcoile's picture
120
Joined: Apr 28 2014 - 2:15am
Last seen: 4 months 3 weeks ago

10 Comments:

#1
  • Reproducibility:Sometimes» Always
  • Assigned:nobody»
#2
  • Status:New» Feedback Requested
  • Assigned:» anonymous

Hi can you attach the report that is causing problems? Or register a screencast?

I tried adding a list with Dataset1. And in Design mode I can drag and drop fields from the dataset.
Not sure I understood how the subreport is involved.

Regards,
Massimo.

#3

My apologies, bad choice of words. I meant in the context of the subdataset of the list, not subreport.

I have it in all lists.

Mac, Java 7, JSS 5.6.1.SNAPSHOT.beta.v201407010859

#4
AttachmentSize
Movie icon screeny_video_03_jul_2014_16.08.07.mov520.39 KB
#5

Hi Marteen,
I just tried. I got the same error when trying to drop the field upon an existing textfield.
For sure this message is not correct and we will fix it. Anyhow if you create space for the drop, you should not have problems.

Regards,
Massimo.

#6

Note: dragging inside the outline from the field list to the detail/frame/list gives the same error.

#7
  • Status:Feedback Requested» Confirmed
  • Assigned:anonymous» mrabbi
#8
  • Resolution:Open» Fixed
  • Status:Confirmed» Resolved
#9

I also got the same error with Jaspersoft Studio. If I drag the fields to main report fields, then the drag/drop to Detail band works. But I'm not sure why I have to do it and also why doesn't the main fields in report do not get the fields selected from Javabean dataset using Collection data source.

#10
  • Resolution:Fixed» Open
  • Status:Resolved» Feedback Requested

Hi,

Do you know if this issue has been fixed? I am still experiencing the same issue.

Thanks.

Feedback