[#3674] - JSS Removes Text Size and a few styles in every case when not using internal preview

Category:
Bug report
Priority:
Immediate
Status:
Feedback Requested
Project: Severity:
Block
Resolution:
Open
Component: Reproducibility:
Always
Assigned to:
0

///// Update:

I just noticed that when I ask JSS to use the Excel preview (where it automatically opens the previewed XLSX file in excel) it REMOVES all size, rotation information and Ignore Pagination. Probably more also.

Compiling the same JSXML using iReport does produce a correct result.

Using JSS 5.6.0; Mac 10.9.3; Java 7

///// OLD:
Hi,

When I compile our reports using the JSS 5.6.0 and upload the .jasper files to our server (integrated with JSL), the font size is reset to size 10.

If we compile the same .jrxml from iReport 5.5.1 and then upload the file to the server, all is fine.
If we open the .jasper from JSS with iReport, then the font size is again reset to size 10.

I will attach the test files.

It's critical for us that JSS works reliable and generates .jasper files that are compatible. What's going on here?

Kind regards,
Maarten @ yesplan

AttachmentSize
Binary Data xlsx_formatting_test.jrxml16.31 KB
v5.6
mvcoile's picture
120
Joined: Apr 28 2014 - 2:15am
Last seen: 11 months 6 days ago

13 Comments:

#1
  • Assigned:nobody»
AttachmentSize
Binary Data xlsx_formatting_test_jss.jasper35.66 KB
#2
  • Assigned:» anonymous
AttachmentSize
Binary Data xlsx_formatting_test_irep.jasper35.93 KB
#3
  • Priority:Urgent» Immediate
  • Severity:Critical» Block
#4
  • Status:New» Feedback Requested
  • Assigned:nobody» mrabbi

Hi Marteen,
can you please try to reproduce the problem with a simpler jrxml and attach it here? Unfortunately I can not use your .jasper files. There are to much references to your workspace libraries/classes.
I tried to replicate the problem copy pasting the frame you had in the column header into a blank JRXML. Anyhow as you can see from the attached screenshot, I was able to see the different texts with their proper sizes. Tested into a Windows XP 32-bit VM with the latest JSS 5.6.0: I used the Excel viewer. I also tested in my development environment (Mac OS X 10.7.5 with Office 2011) and it works fine too.

Did you have any chance to verify if the problem occurs also in different OS/platforms?
I've attached the screenshot + the sample JRXML. Could you please try this one and see if it works fine?

About the Excel exporters: there were important changes introduced in JasperReports 5.5.2. It is possible that there are some bugs on JR side or in JSS as well. I'm pretty sure that iReport did not implemented this new stuff adopting the changes introduced in JR since it is in maintenance mode (only fixes, no new features).
Did you play with the preferences about Excel exporters?

Regards,
Massimo.

AttachmentSize
Image icon previewexcel01.png106.97 KB
Binary Data blank_a4.jrxml3.21 KB
#5

Hi,

Your file has similar problems. albeit less obvious.

No, I did not touch the settings of the exporters. I did set a few paramaters, but even without those, my files are bad.

The problem occurs in the compilation. To see what I am seeing: Build the jrxml into a japer file with JSS and ireport. Open both those files in iReport.

Is it possible for you to inspect the internals of the jasper files?

Kind regards,
Maarten

#6

Hi,
it sounds strange that you are verifying problems also with my JRXML. If you run the preview on it, the resulting output is screwed up? Also opening the output .jasper file is problematic?
Both your attached .jasper files can be opened correctly in my JSS. I see that the text elements have different sizes and formats.

Can you show me a screenshot / screencast of what is happening on your machine?

Regards,
Massimo.

#7

Hi,
I asked also to the JR team to investigate on this. They tested a similar JRXML but it worked fine too.
See the attached JRXML and exported files.

I currently don't have the chance to test into a Mac OS X 10.9.3. I start thinking it environment (maybe OS version) specific. Did you tested on some Linux / Windows configuration the same report?

Regards,
Massimo.

#8

Hello. I face the same problem here when rendering PDFs.
Using 5.5.1 vs. 5.6.0
In both cases I use the compatibility setting for 5.1.0 as the .jasper files are used for rendering by an external tool, using the 5.1.0 jasper jar.
When the attached file is compiled with 5.5.1 it renders the correct font sizes. When compiled with 5.6.0 all textFields use fontsize 10.

AttachmentSize
Binary Data fonttest_5.6.0.jrxml3.17 KB
Binary Data fonttest_5.6.0.jasper19.01 KB
#9

Here the compiled version form 5.5.1

AttachmentSize
Binary Data fonttest_5.5.1.jasper18.98 KB
#10

i Report has the same problem. I just started working with the 5.6.0 (upgraded from 5.5.1) iReport and the compiled jasper files also remove styles.

#11

Hi, until now we were not able to reproduce the behavior.
I've contacted again the JR team for help on the investigation, since the problem seems not to be for JSS only.

Regards,
Massimo.

#12

Update: it's not specific to Excel output.

A change between version 5.5.1 and 5.5.2 on both JSS and iReport causes the .jasper files to either not contain style information or not be backwards compatible.

Kind regards,
Maarten @ yesplan

#13

Has anyone found a solution? I'm testing Jasper Reports Server 6 and I found the same issue with exports to at least xls, xlsx, and PDF documents. I've tried a few reports and the two fonts, DejaVu sans and arial (I added arial to the font library) with the same result.

(My reports are created in iReport 5.1 and our current working server runs jasperreports 5.1)

Feedback
randomness