[#3634] - Apparent bugs in crosstab

Category:
Bug report
Priority:
Normal
Status:
Closed
Project: Severity:
Minor
Resolution:
Unable to Reproduce
Component: Reproducibility:
Unable to Reproduce
Assigned to:
0

In order to get a crosstab to sort on month in descending order, I had to change the month variable to a 2-digit month from month name. We want month name to appear on the report, so I added variable month_name to the main part of the report and then added a row group to use that variable; this is basically the same approach I used to sort columns by last name/first name while displaying first name/last name. As I’ve already seen, adding row groups simply appends them to the end with no apparent facility provided to reorder the groups in Outline view. I thought I’d try to move the group in the Source view but it was nowhere to be found. I thought that maybe I had to go back to the main report and add a group on month_name to get this to work. I deleted the new group and on the main report added a group for month_name. However, it didn’t show up in Outline view nor in Source view. I tried to run the report to see what would happen and got these two errors (FYI, I had to type these because there seemed to be no way to copy/paste):
Reset group “month_name” not found for variable : month_name_COUNT --- net.sf.jasperreports.engine.design.JRDesignVariable@29495306
Reset group “month_name_count” not found for variable : month_name_count_COUNT --- net.nsf.jasperreports.engine.design.JRDesignVariable@30c92353
I hoped to undo what I had done to cause this, but there was no undo available. Fortunately I had not saved since the last working copy so was able to recover. But I’m still left with a puzzle as to how to get the crosstab formatted the way our existing SSRS report is formatted without having to do everything perfectly correct at the start, since there doesn’t seem to be a way to CHANGE the crosstab in any significant way once it’s built.

AttachmentSize
Package icon issueDetails.zip3.83 KB
drummer54's picture
Joined: Mar 17 2014 - 7:34am
Last seen: 6 years 5 months ago

3 Comments:

#1
  • Priority:High» Normal
  • Severity:Critical» Minor
  • Reproducibility:Always» Unable to Reproduce
  • Assigned:nobody» morlandin

But the variable is in the main dataset right? becuase the crosstab has visibility only on his dataset, you should create the group on the subdataset of the crosstab if you want to group the crosstab data. Anyway (except for the undo) it dosen't seems a bug. For the undo i have to investigate, but there are really to few details to reporduce the bug

#2

Thanks for the feedback. I've created multiple versions of this report as I've tried to replicate our current SSRS report and have moved on to other issues since posting this, so am not exactly sure where I left off. Given the problems I've had with changing crosstab groupings once the original groupings are in place, I'll probably have to start from scratch once again to see if I can get this to work properly.

#3
  • Resolution:Open» Unable to Reproduce
  • Status:New» Closed

[CLEANING UP TRACKER]

Feedback
randomness