[#3515] - Studio seems to be leaking memory

Bug report
Feedback Requested
Project: Severity:
Component: Reproducibility:
Assigned to:

If I execute a report with sql statement with errors several times, Studio errors out the out of perm memory error and hangs up.

Image icon memoryleak.png35.21 KB
hozawa's picture
Joined: Apr 24 2010 - 4:31pm
Last seen: 3 years 9 months ago


  • Status:New» Feedback Requested
  • Assigned:nobody»

Hi Hozawa,
can you please elaborate a bit? What do you mean with SQL statement with errors?
Did you try to run report (previewing) using a wrong written query? Or where you using the data preview from inside the Dataset & Query dialog?
I see you wrote down 5.5. Were you able to reproduce also in 5.5.1 or 5.6 beta? I suppose you are using the CE edition. Correct?


  • Assigned:» anonymous

I'm entering sql statements in Query dialog and previewing reports. Unfortunately, the Query dialog is showing errors on all Japanese characters so I'm just previewing the reports to find the actual errors (things like missing quotations and unmatched parenthesis) and sql syntax (I have some parameters in SQL statement)
If I repeat this a couple of times, Studio suddenly freezes and I have to kill the process.
I'm using the Pro version. I made a mistake. I it's 5.5.0 Pro. On Windows 7 64 bit. Using MySQL as the database with MySQL Connector/J.
Everything is working OK if there's not error so I think it's the repeated SQL errors.

Attached Eclipse error log. PermGen space error is when Eclipse freezed and the following errors occur when I restart Eclipse.

Plain text icon log.txt15.56 KB

Hi the related bug http://community.jaspersoft.com/jaspersoft-studio/issues/3514 was marked as resolved.
It can be tested on the latest integration build (https://sourceforge.net/projects/jasperstudio/files/beta-release/). Can you please tell us if the problem of PermGen is gone now that the other problem is solved?



I believe I am experiencing the same problem with the latest build. My log file is attached. I'm on windows 7 using the 32-bit Jaspersoft Studio.

Binary Data log637.23 KB
  • Assigned:anonymous» chicuslavic

could you increaze this parameters (double)?


setup them in eclipse.ini or "Jaspersoft Studio Professional.ini" file, then restart eclipse

  • Priority:High» Normal

I'm having memory leak as well. Actually since version 5.6 and everything in between. Newest version still the same problem, atm memory is 1.3 GB (started at 600 MB) and when it reaches 1.6 GB it will give PerGen errors etc. Will try to increase permsize, but rebooting also 'fixes' the problem for a while.


Hi hozawa,
can you share the report so we can do some tests?


The problem may be related to issue 4768. Studio seems to be leaking memory because I'm still getting perm memory error after using it for couple of hours. It seems to be happening when I switch between preview.