[#14561] - Using hyperlink with target=Blank and type=Reference is not working inside PDF report

Bug report
Project: Severity:
Component: Reproducibility:
Assigned to:

Hi all,

I'm using JasperReports and I have a PDF report which has hyperlink inside it.

When this pdf report is opened in browser, I need it to open this url to open in new tab.

For this purpose I chose target=Blank and and type=Reference.

But its not working.

Also I found many old questions on this forums regarding this issue without any normal work around.

So could you help me with it? Why it's not working? Whats the solution?

shweta_1's picture
Joined: Dec 28 2022 - 11:46pm
Last seen: 1 month 6 days ago



Could please clarify what "not working" means? Is the link not reacting to clicks at all, or is it reacting but not opening the link in a new tab?

Also, which browser are you using?



Hi, i have faced the same issue as well and my settings are hyperlinkType = "Reference" and hyperlinkTarget = "Blank". In the PDF, i am able to see the hyperlink and it is also clickable. However, upon clicking on the hyperlink, nothing happens. On the other hand, i have tried changing the hyperlinkTarget to "Self" and the hyperlink is working if i open the PDF in safari and not Adobe Reader (not sure why i am unable to open the PDF in Chrome). I am using Chrome browser and using Adobe Acrobat Reader to read the PDF generated.


Hello Lucian,
Thanks for the reply. "Not working" means that the link is clickable and I can see the cursor turned to a hand icon, but when I click not it the link doesn't open in new tab.
I have tried this on chrome as well as fire fox. It's the same result in both. Also, downloaded the pdf and opened in Document viewer. The link doesn't work.