[#14046] - too long compilation time for groovy language report

Category:
Bug report
Priority:
Normal
Status:
Closed
Project: Severity:
Major
Resolution:
No Change Required
Component: Reproducibility:
Always
Assigned to:

Hi, i am experiencing long compilation time compiling groovy language report using Jaspersoft Studio 6.19.0; the issue is the same with 6.18.1.
Here my configuration:
Windows 10, 32GB Ram
I extract zip of the application under c:\bin\ and rename folder in jaspersoftstudio-6.19.0, then i run C:\bin\jaspersoftstudio-6.19.0\Jaspersoft Studio.exe

jrxml source code:

<?xml version="1.0" encoding="UTF-8"?>
<!-- Created with Jaspersoft Studio version 6.19.0.final using JasperReports Library version 6.19.0-646c68931cebf1a58bc65c4359d1f0ca223c5e94 -->
<jasperReport xmlns="http://jasperreports.sourceforge.net/jasperreports" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://jasperreports.sourceforge.net/jasperreports http://jasperreports.sourceforge.net/xsd/jasperreport.xsd" name="Blank_A4" language="groovy" pageWidth="595" pageHeight="842" columnWidth="555" leftMargin="20" rightMargin="20" topMargin="20" bottomMargin="20" uuid="be67d886-c636-4f1e-88de-bb69b5eaf8df">
<field name="encounters" class="java.util.List"/>
<detail>
<band height="20">
<textField>
<reportElement x="20" y="0" width="120" height="20" uuid="c0f2bb42-92ad-435d-ad77-381d7cbe2d43"/>
<textFieldExpression><![CDATA[$F{encounters}.isEmpty()]]></textFieldExpression>
</textField>
</band>
</detail>
</jasperReport>

When i launch compilation (from toolbar or right clicking on file -> JasperReports -> Compile report, is the same) it takes 57 seconds to compile this simple jrxml.
if i change report language to java or javascript the compilation time is around 5 seconds.

Why does it take so long to compile groovy report? Am i missing any configurations?
With my old 6.8.0 Studio version the time was way more short (2-3 seconds).

Thank you for your help

regards,
Andrea

v6.18.1
andrea.bortolini's picture
Joined: Oct 20 2021 - 1:27am
Last seen: 2 weeks 1 day ago

8 Comments:

#1

Could you provide a feedback?
Thanks

#2
  • Status:New» Feedback Requested

Hi Andrea,
for sure Groovy compilation and report preview have always been slower compared to the Java ones.
Anyhow your results seem strange.

Can you please detail on your current installation?
> Is it a plugin or RCP one?
> Did you upgrade a previous version of JSS?
> Can you please provide information about your current workspace setup? Projects, additional jars, libraries, how many jrxml etc.

I tried to reproduce your scenario in the simplest environment possible using a "fresh" new workspace with a simple report using a proper Groovy expression.
I performed both report preview and compilation in a Windows (VM) and Mac environment.
You can see the results in the videos uploaded here: https://sourceforge.net/projects/jasperstudio/files/DevelopersInfo/BugAt...

You may notice that there is this strange behavior in Mac taking a lot more compared to Windows. I suspect some kind of OS/file system dependant "issue". We might try to debug further on this.
But indeed the timings are very far from those ones you reported.

Best regards,
Massimo.

#3

Hi Massimo,
thank you for your reply. Here my answers:
> Is it a plugin or RCP one?
they are RCP 6.19.0 and RCP 6.18.1 for Windows. i don't try with previously versions, except RCP 6.8.0 that works fine.
> Did you upgrade a previous version of JSS?
No, i have just downloaded the zip version for Windows from this link https://sourceforge.net/projects/jasperstudio/files/JaspersoftStudio-6.1.... Then i extract as i wrote in my first post.
> Can you please provide information about your current workspace setup? Projects, additional jars, libraries, how many jrxml etc.
I am not using any additional jars, libraries in those attemps. I am using the default workspace (C:\Users\<user>\JaspersoftWorkspace\), default project MyReports. I have just one jrxml, the one i wrote before; it's located under MyReports folder.
I have also tried to switch to new workspace and add new project; i have erased unzipped folder e re-unzip with several attemps but problem remains.

I am experiencing the same problem from several Windows hosts.
On those hosts were previously old versions of jaspersoft studio but every application was from unzipping folders and use different workspaces.
I am also noticing that today the compilation time is faster then few weeks ago, like 15 seconds instead of 57, but still far from yours.

In my further experiments removing the espression $F{encounters}.isEmpty() from textfield results in a fast compilation (1 second) and adding it again raises compilation time as before.

Is it trying to reach any url during compilation?
In your video you are not using my example. Did you try just compiling that one?

best regards,
Andrea

#4

Hi Andrea,
I had already tried with you report, but I preferred to go with a "real" groovy expression that's why I created with that sample expression.
That said, I uploaded to the above SourceForge folder a new recording "runningTestReportAndCompiling.mov".

I tried again running and compiling your report.

As you can see the timings are still far from what you are experiencing. Maybe I'm doing something differently.
That said I've experienced the slowness of Groovy in Mac compared to Windows (also shown in initial videos). Not sure which is the underlying reason.
I also recall that the older jar version, I think it was 2.4.3 in JSS 6.8.0, was faster. "Unfortunately" we had to move forward.

Please provide if you can a registered screencast like mine. Thanks!

Best regards,
Massimo.

#5

Here the link to download the video:
https://drive.google.com/file/d/1pecYhQYNvxthxyMUU_DrN2dS5_S2vcj2/view?u...
Thanks again for you support

#6

Hi Andrea,
I just saw your video. Not sure what is actually the problem here.
Can you provide more details on your machine? For example disk type (SSD or standard HDD), CPU, etc.
Do you have antivirus installed? Maybe try to put in exclusion list the JSS folder and the workspace one for a quick test.

The fact that you see an almost 0 time when removing the expression is be related to the fact that no machinery (with Groovy classloading) should be triggered when an empty textfield is found.

Did you have any chance to maybe test the execution into another OS? For example a Linux or Mac machine (maybe of a colleague).

Regards,
Massimo.

#7

Hi,
sorry for let time pass. After various attempts we uninstall Sophos Antivirus and we got the solution.
JS Studio 6.18.1 compilation time now is less 1 second for our example jrxml.
Thank you for your support
Best regards,
Andrea

#8
  • Resolution:Open» No Change Required
  • Status:Feedback Requested» Closed
Feedback