[#13741] - Bugged Text on Zoom

Category:
Bug report
Priority:
High
Status:
Closed
Project: Severity:
Major
Resolution:
Unable to Reproduce
Component: Reproducibility:
Sometimes
Assigned to:

Whenever zooming in or out of my report editor, text becomes jumbled (all characters stacked on top of each other in the first position). This only happens with Times New Roman font, and if I restart my Studio it will reset until I zoom in or out again.

AttachmentSize
Image icon screenshot_2021-08-04_105604.png12.49 KB
v6.17
Jaspersoft® Studio
rtumminelli's picture
Joined: May 12 2021 - 2:15pm
Last seen: 5 months 3 weeks ago

10 Comments:

#1
  • Status:New» Feedback Requested

Hi, not sure if you are using JSS plugin or the stand-alone installation. Moreover it's not clear which OS you are in.
That said I gave it a try in both latest Mac OS X 11.5.2 and Windows 10. I did not verify you issue (what is shown in the screenshot piece). I used some static text boxes and also some text fields. Played with the zoom from the control and with the shortcuts after having set the "Times New Roman" font. It worked as expected.

Can you please register a screencast with the issue?
Thanks.

Best regards,
Massimo.

#2
  • Priority:Normal» High
  • Severity:Minor» Major
  • Reproducibility:N/A» Sometimes

This happened to me when my co-worker create the report and then I have modified it later. He uses the same jasper studio version 6.14.0

AttachmentSize
File demo.avi1003.62 KB
#3

Hi,
not sure what should be visible in your attached screenshot. There is a static image of the workspace + about dialog open.

Regards,
Massimo.

#4

claspina did not upload a screenshot, it is a video. It is a .avi file. If you watch the video, you can see they open a report file and have the same exact bug I reported. The text is rendered incorrectly and becomes worse when you zoom in or out. I am using the stand alone installation on Windows 10. I recently updated to 6.18 and still get this bug/issue all the time.

#5

Correct, I wrongly typed screenshot but I meant screencast. Unfortunately what I see with this avi file (when played for example in VLC), it's a 27 second of "static image" with the About dialog on top of the workspace files.

Regards,
Massimo.

AttachmentSize
Image icon brokenvideo.png796.95 KB
#6

Please try to make work the video, I open perfectly with the VLC player.

#7

Hi,
not sure why the video is not working on Mac OS X. That said I tried on a Window 10 VM, so I also double checked with both JSS 6.14.0 and 6.18.1 (last available).
I was able to play your video on Windows and I saw the strange issue you have.

Anyhow as you can see from my two screencasts I was not able to verify your problem on my side.
- JSS 6.14.0: https://www.youtube.com/watch?v=GkFd_h6H8sc
- JSS 6.18.1: https://www.youtube.com/watch?v=EsNV0D66_6g

My advice for you is to give it a try to a bunch of additional tests:
- a different JDK/JRE instead of the bundled AdoptOpenJDK one. Therefore you will have to change the -vm flag reference inside the Jaspersoft Studio.ini file
- trying the Jaspersoft Studio Eclipse plugin installation and see if the problems occurs also there
- give it a try on a virtual machine using VirtualBox / VMware
- start with a clean installation of the 6.18.1 and maybe also a new workspace to double check

To me it seems more a configuration/software problem on your systems. I don't recall any similar bugs here or internally.
Could you confirm that this happens with all the reports (involving Times New Roman) or only with specific ones?
Another strange behavior is that you mention "This happened to me when my co-worker create the report and then I have modified it later.".
This means you were able to correctly work with Times New Roman font in reports before? And what if you now create a new one from scratch with static text using Times New Roman, not editing one of your colleague?
That said if possible please try to attach one of the faulty report.

Regards,
Massimo.

#8
  • Resolution:Open» Unable to Reproduce
  • Status:Feedback Requested» Closed

Closing since even in the latest version 6.19.0 I'm not able to reproduce the issue.

Regards,
Massimo.

#9

This issue still plagues me basically every day on 6.18. I tried to upgrade to 6.19 but it looks like the way html is handled/rendered was fundamentally changed because many of my text fields with html content look wrong/different and I don't have the time to go through and figure out how to fix this in hundreds of places.

#10

This has plagued me on versions 7.5, 7.9 and now on 8.0 (Professional). I talked to Tibco support twice now about this and they have no answer and say that no one else has ever reported the problem. The last person I talked to blamed it on my video hardware and/or monitor setup. I've since tried without using any external monitors (I'm on a laptop) and various other monitors other than the original ones I've had. I've also made sure all drivers are updated. Needless to say it made no difference. Oh... and it does it for other fonts for me (I primarily use Arial).

Clearly (after finding this thread) others have experienced the issue and it would seem it goes all the way back to version of 6.x. I'm posting here now in the hopes someone comes along with an answer and I can get notified when it gets posted.

Feedback
randomness