[#13691] - Transparent vs opaque

Category:
Bug report
Priority:
Normal
Status:
Resolved
Project: Severity:
Minor
Resolution:
Fixed
Component: Reproducibility:
Always
Assigned to:
0

The checkbox to set opaque mode on a textbox is reversed. When we check it (to say opaque as the checkbox is labelled), it sets mode"Transparent".

Jaspersoft Studio 6.17.0

razorvla's picture
Joined: Feb 20 2020 - 1:33am
Last seen: 1 week 3 days ago

3 Comments:

#1
  • Status:New» Feedback Requested

Hi not sure what you mean.
I quickly tested in 6.17.0 and the "transparent" attribute behavior appears ok to me.
See attached screenshots.

Regards,
Massimo.

AttachmentSize
Image icon opaque.png126.21 KB
Image icon transparent.png121.09 KB
#2

Here is the same test you did :

Note that the attribute is called "opaque" and not "transparent".

When i check in the source tab, i can see :
<reportElement mode="Opaque" when the checkbox is NOT clicked.

It is maybe just a translation error as my Jaspersoft Studio seems to be in french.

AttachmentSize
Image icon opaque.png20.12 KB
Image icon transparent.png23.78 KB
#3
  • Resolution:Open» Fixed
  • Status:Feedback Requested» Resolved

Hi,
I get what you mean now. Apparently the French translations are not good.
Consider that the main language is English and that the other two language shipped (Italian and French) are for sure not 100% complete.
We started internally as project devs to translate since people of the team were Italian or others knew French.

Feel free to contribute or spot other typos/missing translations.
Marco back in the time wrote an article about the contribution for the translations: https://community.jaspersoft.com/wiki/how-translate-jaspersoft-studio

Regards,
Massimo.

Feedback
randomness