[#13646] - Subreport compilation

Category:
Bug report
Priority:
Normal
Status:
Resolved
Project: Severity:
Minor
Resolution:
Fixed
Component: Reproducibility:
N/A
Assigned to:
0

Hello

We are moving from JasperSoft Studio version 6.8.x to JasperSoft Studio version 6.17.x. In our reports we refer to subreports by filename. If the filename ends with '.jrxml' than JasperSoft Studio version 6.8.x compiled the subreports automatically when the master report was previewed. Very convenient. However in JasperSoft Studio version 6.17.x and JasperSoft Studio version 6.16.x the reports aren't compiled anymore. The build project doesn't work because it tends to recompile all reports that are present in the project explorer. Will this auto compilation be reinstated or is there a way to compile a selection of reports or reports in a particular folder?

Thomas

tcleenewerck_1's picture
Joined: Mar 19 2019 - 7:10am
Last seen: 2 months 1 week ago

1 Comment:

#1
  • Resolution:Open» Fixed
  • Status:New» Resolved

Hi this problem has been fixed and also the compilation speed of many sub-reports related to a single main report should be improved.
The fix will be available in the next upcoming version.

Regards,
Massimo.

Feedback