[#13296] - The Jaspersoft Studio in the macOS Big Sur version is broken (does not repaint screen)

Category:
Bug report
Priority:
None
Status:
Acknowledged
Project: Severity:
Text
Resolution:
Fixed
Component: Reproducibility:
N/A
Assigned to:
18

The Jaspersoft Studio in the macOS Big Sur version is broken. It does not update the view on normal interactions such as clicking, resizing, hovering, editing elements, zooming, etc.

It only repaints its view when getting focus, losing focus and scrolling.

giordano221's picture
Joined: Oct 25 2011 - 7:46am
Last seen: 4 months 5 days ago

47 Comments:

#1

confirmed. me too... resorting in using a VM(Windows) for it

#2

Me too... I'm using parallels with windows like a workaround.

#3

Same issue. Studio 6.16.0 on Big Sur 11.0.1 on MacBook Pro. Original issue description is accurate, making using Studio virtually impossible.

#4

Same Issue here, when will this be fixed?

#5

lamentablemente me encuentro en la misma situación que el resto :(

#6

Same issue here. Is it possible there is an issue with JDK?

#7
  • Priority:Immediate» Urgent
  • Status:New» Confirmed

me too :(

#8

Confirm :-(((

#9
  • Reproducibility:Not Attempted» Always

Same problem here!

#10

Confirmed. Same problem here.

#11

Stesso problema. Ho provato con la 6.11 e la 6.16

#12

Same problem. When I insert or move an image element, text element, or any other kind of element, the change seems to take place but I cannot see the new placement until I select something else. This is very frustrating.

#13

Same issue.. :(

#14

Same issue.

#15

Same issue here....

#16
  • Priority:Urgent» Immediate
  • Severity:Critical» Block

Confirm. Cannot work with macOS Big Sur 11.1.0

#17

Same issue here.

#18

Same issue, extremely frustrating.

#19
  • Severity:Block» Critical

Related issues:
https://community.jaspersoft.com/jaspersoft-studio/issues/13221
https://community.jaspersoft.com/jaspersoft-studio/issues/13256

Looks all the same.

I've contacted TIBCO about this issue they have no plan to "certificate" Studio with MacOs Big Sur :-( Really annoying situation

Can anybody help here?

#20

Same here. Looking into alternatives like plotly.

#21

Can you provide a little more detail on what TIBCO said? Do they ever plan on supporting Big Sur?

#22

Hi all,
I'm attaching here a jar file that can be used to temporarily address the graphical editor issues until there is not an official release.

Here below short instructions:
1. Stop Jaspersoft Studio instance.
2. Locate the installation directory of Jaspersoft Studio: /Applications/TIBCO Jaspersoft Studio 6.16.0.app/.
3. You might want to use the context menu item "Show Package Content" or navigate via terminal to the sub-folder /Applications/TIBCO Jaspersoft Studio 6.16.0.app/Contents/Eclipse/plugins
4. Add the "com.jaspersoft.studio.patch_swt_6.16.0.js-patch01.jar" file via command line or using Finder
5. Restart Jaspersoft Studio normally and verify the problem is solved in the interaction with the design editor.
6. If the problem appears to be still there, try restarting Jaspersoft Studio using the "-clean" flag in order to clear any possible OSGI and Eclipse runtime information that might have been cached and related to plug-ins. The flag can be removed on the next startup, because it usually has impact on startup times.
SAMPLE USAGE: ./Jaspersoft\ Studio -clean (inside the /Applications/TIBCO Jaspersoft Studio 6.16.0.app/Contents/MacOS directory)

I hope that soon we will be able to release a new version with a more effective support to the new Mac OS X version.
Unfortunately it appears that there are also some bugs (BigSur related) that have been solved in the recent 4.18 Eclipse platform, but others are still open and will be addressed in the next 4.19.

Best regards,
Massimo.

#23

@mrabbi,

FYI: I tried using the patch you described above, and also restarted Jasper using the -clean flag. Unfortunately, most of the issues persist. I can tell the patch resolved a couple issues. For example, I can actually see which element I selected on the canvas now. Unfortunately though, most of the re-drawing issues persist, and Jasper is still unusable. For example, something as simple as moving or resizing a text field (or any element) still does not show properly in the designer.

Thanks for your help,

Franck

#24

>>>> Can you provide a little more detail on what TIBCO said? Do they ever plan on supporting Big Sur?

Basically, there is a request for certification, but they don't have plans to support Studio on Big Sur

#25

@freyherme

Can you please provide a screencast with all the glitches you are mentioning?
Thanks in advance.

Regards,
Massimo.

#26

Thank you very much for everything, the patch worked for me, everything is fine!!!!!

#27

@mrabbi,

I'm using Jaspersoft Studio Professional Edition version 7.9.0. Does this patch work only for version 6.16.0? I'll try to make a screencast later today.

Thanks,

Franck

#28

@freyherme

For the Jaspersoft Studio Professional edition you need to open a ticket to support. I can not provide anything outside the official channels.
The PRO version is based on a different platform (4.14) so it might have additional issues. But a properly packaged patch for 7.9.0 could partially address the problem.

The attached patch is meant to work with the CE.
Best regards,
Massimo.

#29

confirmed... this patch so far works ... thanks buddy...

#30

Hi,
Just to add some information : the patch did fixed the refresh issue, but the preview tab is also broken : when scrolling, I only see the upper part of the report, and can't scroll to see the bottom of the page.
Regards

#31

Worked for me on design tab!

#32

It seems to work, I did that copy the .jar file as you indicated and I opened the program and at first sight everything seems to work ok (refresh the screen)

Thanks for the solution!

#33

Thanks! Above patch makes the app useable again.

#34

Hi I also add the patch, but in preview, scroling not working. (repainting problem on preview also)

#35

I initially thought this was the Macbook m1 processor problem but appears I have the same problem with everyone here on the GUI and additionally even the preview.....is there any fix or patch I can do to get Jasper Studio back to working again at least for now

#36

The workaround patch is in the comment #22: https://community.jaspersoft.com/jaspersoft-studio/issues/13296#comment-...

That's all we can provide for now.

#37

Hi all,
I'm adding an additional patch fragment. In this case we are fixing the problem with the scrolling in the Preview editor that some of you reported.
Since there is a new Eclipse 4.19 coming out on March 17, we will try to work on producing a new Jaspersoft Studio Community version based on that and integrating these fixes as soon we can put our hands on the stable version.
Jaspersoft Studio 6.16.0 is based on Eclipse 4.17 as you know and there are some additional glitches that you might have noticed (i.e problems with list components). It seems that some of these problems were solved in 4.18, but more will be addressed in the upcoming 4.19.

So feel free to use a more recent Eclipse 4.18 and install the JSS plug-in from Marketplace. You can later add the two patch fragments as you would do for the standalone version of Studio.

Best regards,
Massimo.

#38
  • Priority:Immediate» Normal
  • Severity:Critical» Major

Thank for these patches. I was dying without them. Seems to be working better.

#39

Awesome, works for me, Thanks!

#40

Hi Thanks mrabbi this works very well! You helped a lot!

#41

Thanks for the patches. They made all the difference in the world.!

#42

@mrabbi I`ll kiss you! Tks! The patches works perfectly! Have a nice day

#43

Would anybody be so kind to clarify how to apply the aforementioned patch?

#44

@mrabbi you saved my life!

#45

@mrabbi I love you!

#46
  • Priority:Normal» None
  • Severity:Major» Text
  • Reproducibility:Always» N/A
  • Resolution:Open» Fixed
  • Status:Confirmed» Acknowledged

@mrabbi Thank you so much. :)

#47

Hello All,

I added the two patches to my BigSur and 6.16 installation and things are working now. Whew! Thanks!!

Feedback
randomness