[#13226] - Subreport can not be found

Category:
Bug report
Priority:
Normal
Status:
New
Project: Severity:
Minor
Resolution:
Open
Component: Reproducibility:
N/A
Assigned to:
0

By clicking on a subreport within a mainreport in Jasperstudio 6.16 and 6.15 the subreport can not be opend. I need to open the subreport explicitly.See the pic please.
(The compiled jrxml exists)

net.sf.jasperreports.engine.JRException: Byte data not found at: qskh_2018_buaw_gruppe_indikator.jasper.
at net.sf.jasperreports.repo.RepositoryUtil.getBytesFromLocation(RepositoryUtil.java:215)
at com.jaspersoft.studio.editor.report.ReportContainer.openEditor(ReportContainer.java:568)
at com.jaspersoft.studio.editor.JrxmlEditor.openEditor(JrxmlEditor.java:144)
at com.jaspersoft.studio.editor.gef.parts.EditableFigureEditPart$1.run(EditableFigureEditPart.java:46)
at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:40)
at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:185)
at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:3987)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3615)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$5.run(PartRenderingEngine.java:1157)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:338)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1046)
at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:155)
at org.eclipse.ui.internal.Workbench.lambda$3(Workbench.java:644)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:338)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:551)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:153)
at com.jaspersoft.studio.rcp.intro.Application.start(Application.java:94)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:203)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:401)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:255)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.base/java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:657)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:594)
at org.eclipse.equinox.launcher.Main.run(Main.java:1465)

AttachmentSize
Image icon unbenannt.png66.09 KB
v6.16.0
iman.gharib's picture
Joined: Nov 18 2015 - 3:46am
Last seen: 4 days 19 hours ago

2 Comments:

#1
  • Assigned:nobody» chicuslavic

could you retry to do the same on the last JSS release?

#2

Hi,I have already updated the bug report. I tried 6.16. The same problem happens with that too

Feedback