[#13221] - JasperStudio 6.15.0 - zoom controls fail to work on MacOS 11.0.1

Category:
Bug report
Priority:
Urgent
Status:
Closed
Project: Severity:
Critical
Resolution:
Duplicate
Component: Reproducibility:
Always
Assigned to:
1

I upgraded my MacOS to BigSur (11.0.1) and afterwards Jasper Studio 6.15.0 did not let me zoom in on the page with either the plus / minus controls or the percentage dropdown list box. I have re-installed 6.15.0 and the problem continues.

v6.15.0
cgaskins's picture
Joined: Aug 6 2019 - 12:25pm
Last seen: 1 month 2 weeks ago

11 Comments:

#1
  • Assigned:nobody» chicuslavic

We don't recommend to update to Mac OSx Big Sur right now. Please, wait a bit. We face problems with many other software too. We'll fix it as soon as possible. I suppose also Apple will release some updates soon.

#2

Understood... Unfortunately, I had to upgrade for other reasons. I am happy to test any fixes/updates if you need the help.

#3
  • Assigned:nobody»

@chicuslavic I think that my issue is same problem as this (MacOS version) https://community.jaspersoft.com/jaspersoft-studio/issues/13256

#4

There all kinds of window refresh issues with Big Sur and Jasper Studio... Here are a few more but this is not an all encompassing list:
- deleting a table does not remove it from the screen but the object goes away in the object explorer
- deleting a graph does not remove it from the screen but the object goes away in the object explorer
- Object Properties explorer (bottom right corner) doesn't properly display after clicking through multiple objects
- Completed report preview sometimes does NOT display the report page until you page forward and backward - typically happens on a multipage report (I don't have the reproduce scenario yet - this is an intermittent problem)

#5

Any updates or estimates as to when this issue might be fixed?

#6
  • Severity:Minor» Critical

When will this issue be fixed?

#7

is there any news?

#8
  • Priority:Normal» Urgent

So I opened this issue back in November.... No changes no updates no nothing. It would be very nice if the someone on the Jasper dev team would respond and at least let us know if this going to be addressed or not... The lack of response (not a fix - just a response) is frustrating.

#9

Please refer to my comment on this thread: https://community.jaspersoft.com/jaspersoft-studio/issues/13296#comment-...
The patch is valid for 6.16.0 version.

#10
  • Status:New» Confirmed
#11
  • Resolution:Open» Duplicate
  • Status:Confirmed» Closed

Closing as duplicate of this: https://community.jaspersoft.com/jaspersoft-studio/issues/13296

Look there for provided patches.
Regards,
Massimo.

Feedback
randomness