[#13136] - 401 (Unauthorized) after Jaspersoft Studio update

Category:
Bug report
Priority:
Urgent
Status:
New
Project: Severity:
Block
Resolution:
Open
Component: Reproducibility:
Always
Assigned to:
0

Jaspersoft Studio has performed some automatic updates this morning and I can no longer connect to any of the servers. There were no configuration or authentication changes on our end. I am able to log into the servers online.

For example, we have this server:
http://10.12.1.48:8080/jasperserver/
un: jasperadmin
Product Version: 7.5.0
Build: 20191206_1440

I am using Jaspersoft Studio v6.15.0 on an iMac / macOS Catalina v10.15.7

A screenshot from the Server Profile Wizard in JasperSoft Studio, showing connection params, is attached (it hasn't changed from immediately prior to the update).

When I click on "Test Connection", I get the following error:

org.apache.http.client.HttpResponseException: status code: 401, reason phrase: 401
at com.jaspersoft.studio.server.protocol.restv2.RESTv2ExceptionHandler.handleException(RESTv2ExceptionHandler.java:67)
at com.jaspersoft.studio.server.protocol.restv2.RestV2ConnectionJersey.doConnectLogin(RestV2ConnectionJersey.java:328)
at com.jaspersoft.studio.server.protocol.restv2.RestV2ConnectionJersey.doConnect(RestV2ConnectionJersey.java:243)
at com.jaspersoft.studio.server.protocol.restv2.RestV2ConnectionJersey.connect(RestV2ConnectionJersey.java:223)
at com.jaspersoft.studio.server.protocol.ProxyConnection.connect(ProxyConnection.java:118)
at com.jaspersoft.studio.server.WSClientHelper.checkConnection(WSClientHelper.java:92)
at com.jaspersoft.studio.server.wizard.ServerProfileWizard.connect(ServerProfileWizard.java:94)
at com.jaspersoft.studio.server.wizard.ServerProfileWizard.access$1(ServerProfileWizard.java:89)
at com.jaspersoft.studio.server.wizard.ServerProfileWizard$2.run(ServerProfileWizard.java:68)
at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:122)

What could I check/test to get the connection restored? I re-verified that user name and password haven't changed, that I can log in with these credentials online, and that this user has the following roles assigned: ROLE_ADMINISTRATOR and ROLE_USER.

Any help is appreciated!

v6.15.0
astrygin's picture
Joined: Apr 17 2020 - 11:54am
Last seen: 4 days 8 hours ago

10 Comments:

#1

I tried re-installing v6.15.0 and then 6.14.0, but neither would work. Had to go back to 6.13.0 -- that's the last version to work / be able to connect to Jaspersoft Server 7.5.0

#2

Did you upgrade from 6.14.0 or 6.13.0? It's not clear which was your original version.
Moveover did you upgrade the RCP version (standalone) or an Eclipse installation with the plugin?

Regards,
Massimo.

#3
  • Assigned:nobody» chicuslavic

Could you verify if you have spaces in organisation field?
Could you look what is sent to the server and back?
I verified with all the servers I have on hand connection works fine for me.

#4

Upgraded from 6.13.0 because 6.14.0 does not work either. Reproducible by multiple people at the company -- 6.14.0 and 6.15.0 simply can't connect to the server, everyone had to roll back to 6.13.0. There are no spaces in the organization field.

Here's what I've tried: I completely uninstalled v6.15.0 and then:
- reinstalled v6.14.0 from this package: https://community.jaspersoft.com/project/jaspersoft-studio/releases (Specifically https://community.jaspersoft.com/project/jaspersoft-studio/releases?rele...)
- then deleted v6.14.0 and reinstalled v6.15.0 again (https://community.jaspersoft.com/project/jaspersoft-studio/releases?rele...)
- then, when that did not work, deleted 6.15.0 and reinstalled 6.13.0 from the same page, which works.

How can I check what is sent to the server and back? If you could let me know, I will reinstall 6.15.0 and compare what's being sent for 6.13.0 v 6.15.0

#5
  • Assigned:nobody»

I am facing the same error here. I am using community edition of Jaspersoft Server. So, I leave the organization field blank. Yet, I face the same error.

#6
  • Assigned:nobody» chicuslavic

I retested on all the servers I have access too, it is working. Could you activate logs or send me the conversation between client and server? with blurred passwords.

#7

@chicuslavic -- please see the question above. How can I activate logs or send the conversation between client and server? Could you please point me to an article that describes how to do this, and I will send you logs and client-server communications. Thank you!

#8
  • Assigned:nobody»

Please keep this report open while I try my best to get the information.

#9

I do not understand that why almost every time I comment on this report, it will remove the assignment.

#10

I found that if the user password has any special character (like '@', '#', etc), this error will occur. Temporary workaround is change the user password to something that does not have special character. But, this is insecure.

Feedback