[#12176] - Upload Reports with Plugin doesn't Work

Category:
Bug report
Priority:
Normal
Status:
Resolved
Project: Severity:
Major
Resolution:
Fixed
Component: Reproducibility:
Always
Assigned to:
0

I've some issues uploading a report to a server using the Eclipse-Plugin (Both fresh installed 6.10)

org.apache.http.client.HttpResponseException: serialization.error
Auf dem Server ist ein Fehler aufgetreten. Versuchen Sie es erneut, oder wenden Sie sich an die Siteadministratoren. (Fehler-UID: 2773320b-5f25-45cb-a25a-55244924527f)

at com.jaspersoft.studio.server.protocol.restv2.RESTv2ExceptionHandler.handleErrorDescriptor(RESTv2ExceptionHandler.java:121)
at com.jaspersoft.studio.server.protocol.restv2.RESTv2ExceptionHandler.handleException(RESTv2ExceptionHandler.java:61)
at com.jaspersoft.studio.server.protocol.restv2.ARestV2ConnectionJersey.toObj(ARestV2ConnectionJersey.java:49)
at com.jaspersoft.studio.server.protocol.restv2.RestV2ConnectionJersey.addOrModifyResource(RestV2ConnectionJersey.java:631)
at com.jaspersoft.studio.server.protocol.ProxyConnection.addOrModifyResource(ProxyConnection.java:332)
at com.jaspersoft.studio.server.publish.Publish.publishResources(Publish.java:189)
at com.jaspersoft.studio.server.publish.Publish.publish(Publish.java:65)
at com.jaspersoft.studio.server.publish.wizard.Publish2ServerWizard$3.run(Publish2ServerWizard.java:309)
at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:122)

Opening the same workspace with Jaspersoft-Studio and uploading the Report to the Repository works.

Checking access.log: Nonworking:
10.0.2.2 - - [07/Oct/2019:07:42:40 -0400] "GET /jasperserver/GetEncryptionKey HTTP/1.1" 200 41
10.0.2.2 - - [07/Oct/2019:07:42:40 -0400] "POST /jasperserver/rest_v2/login HTTP/1.1" 200 -
10.0.2.2 - - [07/Oct/2019:07:42:40 -0400] "GET /jasperserver/rest_v2/serverInfo HTTP/1.1" 200 290
10.0.2.2 - - [07/Oct/2019:07:42:40 -0400] "GET /jasperserver/rest_v2/users/joeuser HTTP/1.1" 403 58
10.0.2.2 - - [07/Oct/2019:07:42:40 -0400] "GET /jasperserver/rest_v2/resources?folderUri=/&recursive=false&sortBy=label&limit=0 HTTP/1.1" 200 1258
10.0.2.2 - - [07/Oct/2019:07:42:40 -0400] "GET /jasperserver/rest_v2/resources/public?expanded=true HTTP/1.1" 404 119
10.0.2.2 - - [07/Oct/2019:07:42:41 -0400] "GET /jasperserver/rest_v2/resources/reports?expanded=true HTTP/1.1" 200 164
10.0.2.2 - - [07/Oct/2019:07:42:41 -0400] "GET /jasperserver/rest_v2/resources?folderUri=/reports&recursive=false&sortBy=label&limit=0 HTTP/1.1" 200 660
10.0.2.2 - - [07/Oct/2019:07:42:42 -0400] "GET /jasperserver/rest_v2/resources/reports/TestReports?expanded=true HTTP/1.1" 200 156
10.0.2.2 - - [07/Oct/2019:07:42:42 -0400] "GET /jasperserver/rest_v2/resources?folderUri=/reports/TestReports&recursive=false&sortBy=label&limit=0 HTTP/1.1" 200 2106
10.0.2.2 - - [07/Oct/2019:07:42:44 -0400] "GET /jasperserver/rest_v2/resources/reports/TestReports/A4_Praxen?expanded=true HTTP/1.1" 404 165
10.0.2.2 - - [07/Oct/2019:07:42:44 -0400] "GET /jasperserver/rest_v2/resources/reports/TestReports/A4_Praxen?expanded=true HTTP/1.1" 404 165
10.0.2.2 - - [07/Oct/2019:07:42:44 -0400] "GET /jasperserver/rest_v2/resources/reports/TestReports/A4_Praxen?expanded=true HTTP/1.1" 404 165
10.0.2.2 - - [07/Oct/2019:07:42:44 -0400] "POST /jasperserver/rest_v2/resources/reports/TestReports/A4_Praxen?createFolders=true&overwrite=true HTTP/1.1" 400 375

Corresponding entry in jasperserver.log:
2019-10-07 07:42:44,842 ERROR SecureExceptionHandlerImpl,http-nio-8082-exec-1:116 - Auf dem Server ist ein Fehler aufgetreten. Versuchen Sie es erneut, oder wenden Sie sich an die Siteadministratoren. (Fehler-UID: a31c86ef-d726-41cd-8af1-a3e846d63972)

thomas.strub's picture
Joined: Oct 2 2019 - 1:07am
Last seen: 12 hours 27 min ago

5 Comments:

#1
  • Status:New» Feedback Requested

Hi,
to understand better. Everything works fine with the Jaspersoft Studio standalone version 6.10, but the Eclipse plug-in 6.10 gives you the problems above?
Which version of Eclipse are you using?

Regards,
Massimo.

#2

Hi Massimo,

yes exactly.

Eclipse 2019-09 with 6.10 Plugin
Eclipse
--launcher.library
C:\Users\tstrub\.p2\pool\plugins\org.eclipse.equinox.launcher.win32.win32.x86_64_1.1.1100.v20190907-0426\eclipse_1902.dll
Jaspersoft Studio feature 6.10.0.final com.jaspersoft.studio.feature.feature.group TIBCO Software Inc.
Additional bundles for the Community Edition 6.10.0.final com.jaspersoft.studio.supplemental.bundles.feature.group Tibco Software Inc.
JasperReports Library Feature 6.10.0.final net.sf.jasperreports.feature.feature.group TIBCO Software Inc.
JasperReports Library Samples Feature 6.10.0.final net.sf.jasperreports.samples.feature.feature.group TIBCO Software Inc.
Jaspersoft Studio Required Bundles Feature 1.0.13 com.jaspersoft.studio.foundation.bundles.feature.group TIBCO Software Inc.
Nebula CDateTime Widget 1.3.0.201812241324 org.eclipse.nebula.widgets.cdatetime.feature.feature.group Eclipse Nebula
Nebula Custom Widget Toolkit 1.1.0.201812241324 org.eclipse.nebula.cwt.feature.feature.group Eclipse Nebula

vs.
Jaspersoft Studio-6.10.0
Jaspersoft Studio
--launcher.library
C:\Program Files\TIBCO\Jaspersoft Studio-6.10.0\\plugins/org.eclipse.equinox.launcher.win32.win32.x86_64_1.1.1000.v20190125-2016\eclipse_1801.dll

Jaspersoft Studio 6.10.0.final com.jaspersoft.studio.rcp.product null
RCP feature for TIBCO Jaspersoft Studio Community 6.10.0.final com.jaspersoft.studio.rcp.feature.feature.group TIBCO Software Inc.
Internationalization Support for TIBCO Jasperosoft Studio 1.0.0.nl com.jaspersoft.studio.i18n.feature.feature.group TIBCO Software Inc.
Jaspersoft Studio feature 6.10.0.final com.jaspersoft.studio.feature.feature.group TIBCO Software Inc.
JasperReports Library Feature 6.10.0.final net.sf.jasperreports.feature.feature.group TIBCO Software Inc.
JasperReports Library Samples Feature 6.10.0.final net.sf.jasperreports.samples.feature.feature.group TIBCO Software Inc.
Jaspersoft Studio Required Bundles Feature 1.0.13 com.jaspersoft.studio.foundation.bundles.feature.group TIBCO Software Inc.
JRE for Jaspersoft Studio 1.8.0.u151 com.jaspersoft.studio.jre.feature.feature.group TIBCO Software Inc.

Before uploading the report to the server I executed some other steps like:
- Creating a Report
- Preview a Report
- Using Repository Explorer
Change jdbc Connections on Server

and all are working in the Eclipse-plugin.

Regards
Thomas

#3
  • Assigned:nobody» chicuslavic

Ok thanks for the additional information. We will give it a look and try to replicate the issue.

Best regards,
Massimo

#4
  • Resolution:Open» Fixed
  • Status:Feedback Requested» Resolved
  • Assigned:chicuslavic» mrabbi

Hi,
after an investigation that involved comparing the different installations with plugin in 4.13 and previous Eclipse versions, we discovered the problem is caused by the following modification introduced in 4.13: https://www.eclipse.org/eclipse/news/4.13/platform_isv.php#javax-injext

Basically this removal of the "javax.inject" creates issues in the Jackson bundle we ship. Since we can not modify the org.eclipse.core.runtime plug-in, we tried adding the dependency on the MANIFEST.MF of the com.jaspersoft.studio.bundles.jackson plug-in and it seems it worked fine solving the issue.

We will probably release a newer minor version soon that will fix this.

In the meanwhile, you can use a 4.12 version of Eclipse or rely on the RCP product version.

Best regards,
Massimo.

#5

Hi,

thanks for investigation.
Until the fix I will use the packaged version.

Best regards,
Thomas

Feedback