[#12061] - Report designer broken (does not repaint screen) on Linux

Category:
Bug report
Priority:
High
Status:
Feedback Requested
Project: Severity:
Major
Resolution:
Fixed
Component: Reproducibility:
Always
Assigned to:
11

The report designer in the Linux GTK version is broken. It does not update the view on normal interactions such as clicking, resizing, hovering, editing elements, zooming, etc.

It only repaints its view when getting focus, losing focus and scrolling.

See the attached video for an example.

I'm using Ubuntu 18.04.2 LTS on GNOME Shell.

AttachmentSize
File recording1-2019-08-06_07.03.49.mkv1.26 MB
v6.9.0
iReport Designer
fabio.fbsistemas's picture
Joined: Aug 6 2019 - 2:13am
Last seen: 9 months 3 weeks ago

24 Comments:

#1

I've got the same Problem using Debian Linux Stretch with KDE and Using Java 11.

Actually the problem appeared already about a year ago with Jaspersoft Studio 6.x (I don't remember the exact version).
When I use the standalone version of the designer it works most of the time, at least well enough so you can work with it.

#2

ups, actually Debian Linux Buster. But had the same problem in Stretch.
Eclipse version used is 2019-06 (4.12.0). But there was the same problem with previous ones for quite a while.

#3

I'm using the .deb version, which comes with its own JRE (Java 8) in /opt/tibco/TIB_js-studiocomm_6.9.0/features/jre.linux.gtk.x86_64.feature_1.8.0.u151/jre

#4

Same problem on ubuntu 18.04 (using gnome shell), migrating from previous 6.8 DEB package to 6.9

#5

Exactly the same issue here. Kde Neon (Ubuntu 18.04)

#6

Just tested with IceWM on my system, and it doesn't change. It's not some compositing issue.

I've tested 6.9.0 by running the version in the TGZ right from GitHub. It also shows this bad behavior.

HOWEVER... the previous version, 6.8.0, works fine.

#7

New system here: Ubuntu Disco Dingo 19.04 running KDE Plasma 5.15.4

Version 6.9.0 : Broken
Version 6.8.0 : Works fine

#8

Please if you are affected by this bug, upvote it for visibility.

#9

Upvoted. Same issue regardless of distro or desktop. Reverted back to 6.8.0 and now it's fine.

#10

Same Bug in 6.10.0 / Debian Buster

#11

Since ver. 6.9 this bug occurs... Linux (ubuntu: 18.04, 18.10, 19.04 | Mint: 19.2, 19.3), in Windows works well.

#12
  • Status:New» Acknowledged

Hi guys,
the platform changed in the latest two releases.
We moved to 4.11 in JSS 6.9.0 and 4.12 in JSS 6.10.0. There might be some problems related to the platform upgrade (from 4.7.3a in 6.8.0) in combination with the different version of SWT/GTK in the Linux systems.

We will try to give a look into it.

Best regards,
Massimo.

P.S: if possible let us know if you had the same issue working on both JSS plugin and RCP. Moreover if you experienced similar problems with other Eclipse based products or Eclipse itself, let us know!

#13

SAme bug on debian

work with 6.8
Doesn't work with 6.10

#14

same here, Jaspersoft Studio 6.9.0 and Ubuntu 18.04.03 LTS

#15

Same problem. Jaspersoft Studio 6.10.0 on ubuntu 19.10 GNOME 3.34.1.

#16

same problem JSS 6.10.0, ubuntu 18.04.03

#17
  • Resolution:Open» Fixed
  • Status:Acknowledged» Resolved

We introduced some fixes in order to overcome the problem introduced by the change of target platform used to build the product.

#18

Same problem, ubuntu 18.04, JSS 6.9.0 and 6.10.0 have the same behaviour.

#19

Where can I get the fixed version please ? (I downloaded the latest version TIB_js-studiocomm_6.10.0_linux_x86_64.tgz but the release date is 2019-Oct-01 and the issue is still present)

#20
  • Severity:Block» Major
  • Resolution:Fixed» Open
  • Status:Resolved» Confirmed

same here, Jaspersoft Studio 6.9.0 and also 6.10.0 and Ubuntu 18.04.03 LTS

#21
  • Resolution:Open» Fixed
  • Status:Confirmed» Resolved

Please do not re-open the bug. As mentioned in my previous comment we introduced fixes for the problem.
The new build it's still not ready. I can not give a precise release date, but it will be available soon.

Regards,
Massimo.

#22

Waiting for the fix, Jaspersoft Studio 6.9.0 and also 6.10.0 and Ubuntu 18.04.03 LTS

#23

hey there,
same here.

I have been struggling with this for >1 years, but I don't know exact version of studio, when this started.
ubuntu 19.04/19.10 with adoptopenjdk 11, openjdk-8, openjdk-11

#24
  • Status:Resolved» Feedback Requested

Same error here, i need this tool to make my reports, pls help

Feedback
randomness