[#12026] - NoClassDefFoundError when trying to deploy to server after upgrading to Jaspersoft Studio 6.9.0

Category:
Bug report
Priority:
Immediate
Status:
New
Project: Severity:
Block
Resolution:
Open
Component: Reproducibility:
Always
Assigned to:
0

User upgraded Jaspersoft Studio to version 6.9.0. After upgrade, when they try to deploy a report to the server, they get this exception:

java.lang.NoClassDefFoundError: com/jaspersoft/studio/server/protocol/restv2/ClientQueryMapperProvider
at com.jaspersoft.studio.server.protocol.restv2.RestV2ConnectionJersey.connect(RestV2ConnectionJersey.java:174)
at com.jaspersoft.studio.server.protocol.ProxyConnection.connect(ProxyConnection.java:102)
at com.jaspersoft.studio.server.WSClientHelper.checkConnection(WSClientHelper.java:92)
at com.jaspersoft.studio.server.wizard.ServerProfileWizard.connect(ServerProfileWizard.java:94)
at com.jaspersoft.studio.server.wizard.ServerProfileWizard.access$1(ServerProfileWizard.java:89)
at com.jaspersoft.studio.server.wizard.ServerProfileWizard$2.run(ServerProfileWizard.java:68)
at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:122)

I also upgraded to Jaspersoft Studio 6.9.0 and I do not get this error.

User cannot deploy reports to server until this issue is resolved.

Jaspersoft® Studio
valeskyt's picture
Joined: Jul 25 2018 - 9:11am
Last seen: 2 days 2 hours ago

6 Comments:

#1
  • Reproducibility:Random» Always

I am having the same issue just trying to create and test a new connection. When I open my older copy of Jaspersoft Studio it connects via REST just fine.

#2

I am also seeing the same behaviour. I have made a new installation of JasperReports Server and Jaspersoft Studio 6.9.0. When I try to connect to JasperReports Server from Jaspersoft Studio I am seeing the same error message.

#3

I am also having this problem.The version is 6.9.0.

#4

I have same issue and same error.

#5

I have same issue and same error.

#6

Same issue for me as well

Feedback
randomness