[#11706] - StackOverflowError in Crosstab Dataset

Category:
Bug report
Priority:
Normal
Status:
Closed
Project: Severity:
Major
Resolution:
No Change Required
Component: Reproducibility:
Unable to Reproduce
Assigned to:
0

Steps to reproduce:
1. open the attached report (containing 2 crosstabs)
2. click on the first crosstab, then in Properties on the Dataset tab

in the .log file, the StackOverflowError is generated. Afters several such events, Studio might eat up all the resources, resulting in not responding.

java.lang.StackOverflowError
at org.eclipse.e4.ui.workbench.modeling.ElementMatcher.select(ElementMatcher.java:68)
at org.eclipse.e4.ui.internal.workbench.ModelServiceImpl.findElementsRecursive(ModelServiceImpl.java:153)
at org.eclipse.e4.ui.internal.workbench.ModelServiceImpl.findElementsRecursive(ModelServiceImpl.java:244)
at org.eclipse.e4.ui.internal.workbench.ModelServiceImpl.findElementsRecursive(ModelServiceImpl.java:244)
at org.eclipse.e4.ui.internal.workbench.ModelServiceImpl.findElementsRecursive(ModelServiceImpl.java:290)
at org.eclipse.e4.ui.internal.workbench.ModelServiceImpl.findElementsRecursive(ModelServiceImpl.java:244)
at org.eclipse.e4.ui.internal.workbench.ModelServiceImpl.findElementsRecursive(ModelServiceImpl.java:244)
at org.eclipse.e4.ui.internal.workbench.ModelServiceImpl.findElementsRecursive(ModelServiceImpl.java:244)
at org.eclipse.e4.ui.internal.workbench.ModelServiceImpl.findElementsRecursive(ModelServiceImpl.java:244)
at org.eclipse.e4.ui.internal.workbench.ModelServiceImpl.findElements(ModelServiceImpl.java:397)
at org.eclipse.e4.ui.internal.workbench.ModelServiceImpl.findElements(ModelServiceImpl.java:383)
at org.eclipse.e4.ui.internal.workbench.ModelServiceImpl.find(ModelServiceImpl.java:416)
at org.eclipse.ui.internal.WorkbenchPage.findSharedArea(WorkbenchPage.java:3029)
at org.eclipse.ui.internal.WorkbenchPage.findActiveEditor(WorkbenchPage.java:2124)
at org.eclipse.ui.internal.WorkbenchPage.getActiveEditor(WorkbenchPage.java:2065)
at com.jaspersoft.studio.utils.SelectionHelper.getActiveJRXMLEditor(SelectionHelper.java:158)
at com.jaspersoft.studio.editor.expression.ExpressionEditorSupportUtil.getReportExpressionContext(ExpressionEditorSupportUtil.java:165)
at com.jaspersoft.studio.utils.ModelUtils.getElementExpressionContext(ModelUtils.java:1494)
at com.jaspersoft.studio.model.APropertyNode.getExpressionContext(APropertyNode.java:136)
at com.jaspersoft.studio.model.APropertyNode.postDescriptors(APropertyNode.java:105)
at com.jaspersoft.studio.components.crosstab.model.MCrosstabDataset.postDescriptors(MCrosstabDataset.java:75)
at com.jaspersoft.studio.model.APropertyNode.getPropertyDescriptors(APropertyNode.java:89)
at com.jaspersoft.studio.model.dataset.MElementDataset.setGroupItems(MElementDataset.java:138)
at com.jaspersoft.studio.components.crosstab.model.MCrosstabDataset.postDescriptors(MCrosstabDataset.java:88)
at com.jaspersoft.studio.model.APropertyNode.getPropertyDescriptors(APropertyNode.java:89)
at com.jaspersoft.studio.model.dataset.MElementDataset.setGroupItems(MElementDataset.java:138)
at com.jaspersoft.studio.components.crosstab.model.MCrosstabDataset.postDescriptors(MCrosstabDataset.java:88)
at com.jaspersoft.studio.model.APropertyNode.getPropertyDescriptors(APropertyNode.java:89)
at com.jaspersoft.studio.model.dataset.MElementDataset.setGroupItems(MElementDataset.java:138)
at com.jaspersoft.studio.components.crosstab.model.MCrosstabDataset.postDescriptors(MCrosstabDataset.java:88)
......

AttachmentSize
Binary Data report_with_crosstab.jrxml10.99 KB
v6.6.0
jenny_smith's picture
Joined: May 4 2011 - 5:59am
Last seen: 9 months 3 weeks ago

3 Comments:

#1

Hi,

Is your report only used to display the 2 crosstabs ? If that is right you should first delete all the others bands.
Otherwise, you say 'click on the first crosstab, then in Properties on the Dataset tab'. I don't have a 'Properties' section in the Datset tab.
And if you talk about the 'advanced\properties' section, what is the next step to do within?
Your release of Jasper Studio is ?

Regards,
Yann

#2

The attached report was made for test, after discovering the problem, and I removed the unnecessary content.
I clicked on the first crosstab, then in the Properties view on Dataset tab, then in the report on the second crosstab, then in the Properties View on the Dataset tab, then gone back to the first crosstab and clicked on the Advanced tab in the Properties view, then on the second crosstab and on the Advanced tab in the Properties view.

The problem is related to having at least 2 crosstabs in a report.
It seems to be solved on version 6.9.0.

#3
  • Reproducibility:Always» Unable to Reproduce
  • Resolution:Open» No Change Required
  • Status:New» Closed
  • Assigned:nobody» morlandin

Hi, I've tested with the last version and I was not able to reporduce it, so since the 6.6.0 is pretty old probably it has already been fixed

Feedback
randomness