[#11686] - JSS Build Path no longer processes external JARs

Category:
Bug report
Priority:
High
Status:
Closed
Project: Severity:
Major
Resolution:
Unable to Reproduce
Component: Reproducibility:
Always
Assigned to:
0

Apparently starting with v 7.1, we can no longer add an external JAR file (i.e. scriptlets or static helper classes/methods) into the build path of a Jasper Project and have the system find said code. In 6.4.2 and earlier versions, this works as expected. But now one seems to have to drop the JAR file into the JSS plugins folder and restart the application (not desirable). Can someone fix this regression.

mbielkiewicz's picture
Joined: Feb 23 2014 - 9:22pm
Last seen: 8 months 3 days ago

4 Comments:

#1
  • Status:New» Feedback Requested

Hi,
jar files in the project if added correctly to classpath should work fine. While on the other side the files dropped in the JSS plugins folder are jar, but OSGI or plug-in bundles, not the normal stuff containing scriptlets and generic helper classes.
Please since you are referring also to a Professional version (7.1.0), open an entry on the internal tracker with all the information, including a screencast or detailed steps. More, if you have the files/jar(s) you mentioned please attach them.

Thanks!
Best regards,
Massimo.

#2
  • Assigned:nobody» mrabbi
#3
  • Resolution:Open» Unable to Reproduce
  • Status:Feedback Requested» Closed
#4

[CLEANING UP TRACKER]
I suppose this is an old problem that tackled internally (as per my comment) or maybe just a misconfiguration. No further updates have been posted.
My observation about how to use the different "type" of jars are still valid when talking about (fragment) patches for example or workspace/external jars to be added via "Build Path".

Best regards,
Massimo.

Feedback