[#11436] - Null pointer exception when opening report

Category:
Bug report
Priority:
Normal
Status:
New
Project: Severity:
Major
Resolution:
Unable to Reproduce
Component: Reproducibility:
Always
Assigned to:
0

ENTRY org.eclipse.ui.workbench 4 2 2018-12-14 22:43:15.206
!MESSAGE Problems occurred when invoking code from plug-in: "org.eclipse.ui.workbench".
!STACK 0
java.lang.NullPointerException
at com.jaspersoft.studio.toolbars.CommonToolbarHandler.findToolbar(CommonToolbarHandler.java:259)
at com.jaspersoft.studio.toolbars.CommonToolbarHandler.removeToolbar(CommonToolbarHandler.java:278)
at com.jaspersoft.studio.toolbars.CommonToolbarHandler.clearToolbars(CommonToolbarHandler.java:130)
at com.jaspersoft.studio.editor.JrxmlEditorContributor.setActivePage(JrxmlEditorContributor.java:222)
at com.jaspersoft.studio.editor.JrxmlEditorContributor$PartListener.partActivated(JrxmlEditorContributor.java:320)
at org.eclipse.ui.internal.WorkbenchPage$15.run(WorkbenchPage.java:4999)
at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
at org.eclipse.ui.internal.WorkbenchPage.firePartActivated(WorkbenchPage.java:4996)
at org.eclipse.ui.internal.WorkbenchPage.access$19(WorkbenchPage.java:4975)
at org.eclipse.ui.internal.WorkbenchPage$E4PartListener.partActivated(WorkbenchPage.java:212)
at org.eclipse.e4.ui.internal.workbench.PartServiceImpl$3.run(PartServiceImpl.java:250)
at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
at org.eclipse.e4.ui.internal.workbench.PartServiceImpl.firePartActivated(PartServiceImpl.java:247)
at org.eclipse.e4.ui.internal.workbench.PartServiceImpl.activate(PartServiceImpl.java:756)
at org.eclipse.e4.ui.internal.workbench.PartServiceImpl.activate(PartServiceImpl.java:681)
at org.eclipse.e4.ui.internal.workbench.PartServiceImpl.activate(PartServiceImpl.java:676)
at org.eclipse.e4.ui.internal.workbench.PartServiceImpl.hidePart(PartServiceImpl.java:1323)
at org.eclipse.ui.internal.WorkbenchPage.hidePart(WorkbenchPage.java:1591)
at org.eclipse.ui.internal.WorkbenchPage.hidePart(WorkbenchPage.java:1542)
at org.eclipse.ui.internal.WorkbenchPage.closeEditors(WorkbenchPage.java:1512)
at org.eclipse.ui.internal.WorkbenchPage.closeEditor(WorkbenchPage.java:1637)
at com.jaspersoft.studio.editor.AbstractJRXMLEditor$6.run(AbstractJRXMLEditor.java:496)
at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:37)
at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:182)
at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:4034)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3701)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$5.run(PartRenderingEngine.java:1150)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1039)
at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:153)
at org.eclipse.ui.internal.Workbench.lambda$3(Workbench.java:680)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:336)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:594)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:148)
at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:151)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:653)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:590)
at org.eclipse.equinox.launcher.Main.run(Main.java:1499)

kdavidson's picture
Joined: Aug 24 2018 - 7:08am
Last seen: 1 month 4 days ago

3 Comments:

#1
  • Resolution:Open» Unable to Reproduce
  • Assigned:nobody» morlandin

Hi, does this happen every time? With version are you using? Are you using the plugin or standalone version? I'm trying to reproduce the bug so any additional info can be helpful.

#2

Hey, I can get you more information when I'm home this evening. I just wanted to follow up since you're looking at it so that you know I'm not ignoring your question. This looks like it's only an issue on my MAC, my work machine doesn't have this issue, even with what looks to be the same configuration. In both instances I'm running:

Oxygen.3a Release (4.7.3a)

With the following plugins:
Angular JS Eclispe 1.2.0
CodeMix CI 2018.12.13
EclEmma Java Code Coverage 3.1.1
Spark Builder Generator 0.0.21
Tern Eclipse IDE 1.2.0

My work and home Eclipse work spaces are configured exactly the same, except obviously for the differences caused by OS.

I'm using Jasper 6.5.1 due to the requirement of compiling on Java 7, any version later than this does not allow Java7 compile and throws the incorrect class version exception while attempting to run.

The steps I use to replicate it are:
- Create a new project
- Create a new report
- Attempt to open the report

and that NPE happens. There isn't much else available. I've looked through the logging, and there isn't anything other than that. Let me know if there is anything else I can do to help follow up.

#3

Same error here and occurs everytime I open a jrxml file, so I'm unable to edit them:
java.lang.NullPointerException
at com.jaspersoft.studio.toolbars.CommonToolbarHandler.findToolbar(CommonToolbarHandler.java:259)
at com.jaspersoft.studio.toolbars.CommonToolbarHandler.removeToolbar(CommonToolbarHandler.java:278)
at com.jaspersoft.studio.toolbars.CommonToolbarHandler.clearToolbars(CommonToolbarHandler.java:130)
at com.jaspersoft.studio.editor.JrxmlEditorContributor.setActivePage(JrxmlEditorContributor.java:222)
at com.jaspersoft.studio.editor.JrxmlEditorContributor$PartListener.partActivated(JrxmlEditorContributor.java:320)
at org.eclipse.ui.internal.WorkbenchPage$4.run(WorkbenchPage.java:5083)
at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:45)
at org.eclipse.ui.internal.WorkbenchPage.firePartActivated(WorkbenchPage.java:5080)
at org.eclipse.ui.internal.WorkbenchPage.access$3(WorkbenchPage.java:5056)
at org.eclipse.ui.internal.WorkbenchPage$E4PartListener.partActivated(WorkbenchPage.java:214)
at org.eclipse.e4.ui.internal.workbench.PartServiceImpl$3.run(PartServiceImpl.java:253)
at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:45)
at org.eclipse.e4.ui.internal.workbench.PartServiceImpl.firePartActivated(PartServiceImpl.java:250)
at org.eclipse.e4.ui.internal.workbench.PartServiceImpl.activate(PartServiceImpl.java:775)
at org.eclipse.e4.ui.internal.workbench.PartServiceImpl.activate(PartServiceImpl.java:684)
at org.eclipse.e4.ui.internal.workbench.PartServiceImpl.activate(PartServiceImpl.java:679)
at org.eclipse.e4.ui.workbench.addons.minmax.TrimStack.showStack(TrimStack.java:984)
at org.eclipse.e4.ui.workbench.addons.minmax.TrimStack.lambda$3(TrimStack.java:384)
at org.eclipse.e4.ui.services.internal.events.UIEventHandler.lambda$0(UIEventHandler.java:38)
at org.eclipse.swt.widgets.Synchronizer.syncExec(Synchronizer.java:236)
at org.eclipse.ui.internal.UISynchronizer.syncExec(UISynchronizer.java:147)
at org.eclipse.swt.widgets.Display.syncExec(Display.java:4580)
at org.eclipse.e4.ui.internal.workbench.swt.E4Application$1.syncExec(E4Application.java:219)
at org.eclipse.e4.ui.services.internal.events.UIEventHandler.handleEvent(UIEventHandler.java:38)
at org.eclipse.equinox.internal.event.EventHandlerWrapper.handleEvent(EventHandlerWrapper.java:205)
at org.eclipse.equinox.internal.event.EventHandlerTracker.dispatchEvent(EventHandlerTracker.java:203)
at org.eclipse.equinox.internal.event.EventHandlerTracker.dispatchEvent(EventHandlerTracker.java:1)
at org.eclipse.osgi.framework.eventmgr.EventManager.dispatchEvent(EventManager.java:233)
at org.eclipse.osgi.framework.eventmgr.ListenerQueue.dispatchEventSynchronous(ListenerQueue.java:151)
at org.eclipse.equinox.internal.event.EventAdminImpl.dispatchEvent(EventAdminImpl.java:132)
at org.eclipse.equinox.internal.event.EventAdminImpl.sendEvent(EventAdminImpl.java:75)
at org.eclipse.equinox.internal.event.EventComponent.sendEvent(EventComponent.java:44)
at org.eclipse.e4.ui.services.internal.events.EventBroker.send(EventBroker.java:55)
at org.eclipse.e4.ui.workbench.UIEvents.publishEvent(UIEvents.java:378)
at org.eclipse.e4.ui.workbench.UIEvents.publishEvent(UIEvents.java:347)
at org.eclipse.e4.ui.internal.workbench.ModelServiceImpl.bringToTop(ModelServiceImpl.java:607)
at org.eclipse.e4.ui.internal.workbench.PartServiceImpl.delegateBringToTop(PartServiceImpl.java:791)
at org.eclipse.e4.ui.internal.workbench.PartServiceImpl.bringToTop(PartServiceImpl.java:404)
at org.eclipse.ui.internal.WorkbenchPage.bringToTop(WorkbenchPage.java:1068)
at org.eclipse.ui.internal.views.log.LogView.lambda$8(LogView.java:1104)
at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:40)
at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:185)
at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:3919)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:3550)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine$5.run(PartRenderingEngine.java:1173)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:339)
at org.eclipse.e4.ui.internal.workbench.swt.PartRenderingEngine.run(PartRenderingEngine.java:1062)
at org.eclipse.e4.ui.internal.workbench.E4Workbench.createAndRunUI(E4Workbench.java:156)
at org.eclipse.ui.internal.Workbench.lambda$3(Workbench.java:636)
at org.eclipse.core.databinding.observable.Realm.runWithDefault(Realm.java:339)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:563)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:151)
at org.eclipse.ui.internal.ide.application.IDEApplication.start(IDEApplication.java:155)
at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:203)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:137)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:107)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:400)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:255)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:498)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:659)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:595)
at org.eclipse.equinox.launcher.Main.run(Main.java:1501)

I'm using Eclipse 2018-12 with plugin version 6.0 AND JasperSoft Studio 6.0, both with the same problem.

Feedback